Problems with installing NC AIO behind a DynDNS (Strato.de)

Hi all!

I am trying to set up Nextcloud AIO on a fresh Debian Bookworm AMD64-Install. The idea is to run Nextcloud in my local network and open it via DynDNS to the internet. What I did so far is:

My problem is: When I run the install on https://192.168.178.41:8080/containers I get this error via sudo docker logs -f nextcloud-aio-mastercontainer

"NOTICE: PHP message: The response of the connection attempt to "http://mydomain.de:443" was:Bad Request Your browser sent a request that this server could not understand. Reason: You're speaking plain HTTP to an SSL-enabled server port. Instead use the HTTPS scheme to access this URL, please."

I have not yet changed any config files. Does anybody know what I can do from here? I have set up the DynDNS yesterday morning, so - according to my provider - it should work now (they said it takes up to 24 hours)

I have no idea what to do now…
Thanks in advance!

Hi, have you forwarded port 443 to port 443 of thr server? Also, can you check if you are behind cgnat?

1 Like

Hi!
Thanks for the answer, problem is solved now…I ljust ooked at the logs for my fritz box and it said “Bad Auth” for the Dyndns…because I had entered my password for the Strato-user login as the DynDNS-Password and had not configured a special DynDNS-password there. Did that, now NC installs just fine. Phew…glad it was my own stupidity :smiley:

Thanks again & hope you have a nice day! :slight_smile:

2 Likes