Problems with installation - Nextcloud Box

So far disappointed with my Nextcloud Box.

I have had it connected to my BT Home Hub with access via my desktop PC browser over wifi. I have transferred files to and from the Nextcloud Box hard disk and it has worked correctly for two or three hours. Then I lose access. If I try to access from another device, I lose access immediately

I have restarted from scratch ( about a dozen times encountering the same results.

This morning, after running out of any other options, I replaced the Raspberry Pi and now I have no access at all.

Is anybody having the same problems as me or can anyone can offer me any assistance?

With the same model and version number? The supplied image wasn’t compatible with the latest revision of the pi2 I believe, but there are newer images now available to try.

Hi Jason,
Yes with the same model and version. I’ve read one of your replies to someone about the differences between RPi 2 Model B v1.1 and RPi Model B+ v1.2 and I was aware that one would be compatible and one wouldn’t. The replacement was the same as the first, RPi 2 Model B v1.1.

I seem to have explored most options to solve my problem but this is a new area for me so I need some assistance as to where next to go. Do I now suspect that something is wrong in the code on the microSD card? Should I now be looking at alternative images?

I have seen an error message occasionally whilst I have been trying to solve my problem. I didn’t make a note of it but it said something about an inability to write and when I clicked on the link it took me to the Nextcloud online manual but with no specific help.

What really puzzles me is that it can work quite successfully for a couple of hours before I lose the ability to access it over my browser. My BT Hub tells me that the Nextcloud Box still has a presence but I have lost access via the browser. This suggests that I have installed it correctly but there is something going wrong that takes a couple of hours before it corrupts my ability to access.

So if you’re comfortable with the idea, when it goes offline in the browser you could attempt to SSH in and check the status of the box. Write errors don’t sound promising, but without concrete captured messages it’s difficult to say what’s happening.

If SSH isn’t an option, plug it into a TV and go in with a keyboard.

I have tried SSH but I am asked for a password and I do not know which password I am being asked for. I have tried all the passwords that seem obvious but none work. After three attempts I am asked for a ‘public key’ but I do not know know what this means or how to get one.

I have tried a keyboard and a monitor connected to the RPi but not when it has been connected via Ethernet cable to the local area network. There was an error message that told me that ‘printk was being exceeded’. I googled this but could not understand what it meant or how to fix it.

I realise that I now have to see what’s happening when the RPi is connected to the local area network. I shall make that my next task and then, if you don’t mind, come back to you with some more information.

Thanks for your help so far.

No worries, if I’m not mistaken and you’re still using the older image, both username and password are ubuntu.

I could be wrong though as I changed it on mine.

I cannot work out why I am having such little success. I have replaced the second RPi with the original one, the one I have had some success with. However, When the RPI is initialising, I get a message telling me that kernel modules have failed to load. I do not know how important this is because I can still get access to the filing system and upload and download files as if the system is working normally.

However, after a period of two or three hours or if I try to gain access from a different device, my Android tablet for example, I get an error message saying:

“Cannot write into “config” directory!
This can usually be fixed by giving the webserver write access to the config directory.”

Then I can get no more access and I cannot find the config directory only a config file on the microSD card. Even if I could find it, I am not sure how I would resolve the issue.

I am thinking now that my best option might be to download a fresh installation onto a blank microSD card. I have seen these referred to but I would be grateful if you could point me at the correct one unless, of course, you may be able to suggest a better course of action.

With regard to SSH, ‘ubuntu’ was the first password I tried but with no success. However, I suppose my lack of success with SSH may be to do with the ‘write access’ error.

Another thing that is troubling me is that I cannot determine how I got into this position in the first place. I am frustrated when I read that other users have had so little problems and their Nextcloud Boxes have worked successfully right-out-of-the-box. I thought I had faithfully followed the installation instructions and I cannot work out where I went wrong.

Hi Jim,

If your HDD is faulty it may be putting the system infrequently into R/O mode, however you’d only be able to verify that via SSH or by plugging it into another machine and running a SMART check on it. It wouldn’t be impossible for that to be the case.

Once the NC Box is setup it essentially only uses the SD card to redirect the system to the HDD for boot.

Try a new image above, if it happens again I’d suggest looking to get it replaced under warranty.

Thanks for the response and thanks for the links.

I had not considered that the HDD might be faulty, I just assumed it was the software or the RPi. That’s given me a new direction to think about.

I will let you know how I get on.

1 Like

I said that I would let you know how I got on. Unfortunately, I still have no success.

The HDD has been replaced, or checked, so I can now assume that it is not faulty. However, re-assembling the whole boxful and re-trying to get access over my browser, I have had less success than before. I can determine the RPi is connected to the LAN but I have no access at all, not even the limited access I had before.

My focus is now on flashing a new image onto a micro SD card. This is challenging me more than I thought it would but I will persevere with this unless you have any other suggestion.

I really don’t understand why I am finding it so difficult.

Starting fresh is a great idea and will rid you of any doubt there’s an issue with the image currently on there. Once you flash remember to leave it 10 or so minutes to configure.

After which if your LAN supports it you can access the box via http://ubuntu-standard.local - if not, find it through DHCP reservations on your router.

I have successfully flashed a new image onto a micro sd card and it has booted the RPi and I have also successfully accessed the RPi via SSH using PuTTy.

So, I now know that the RPi is working, there is a new image on the micro sd card (that I have updated using sudo apt-get), the HDD is not faulty, and the RPi is connecting to the LAN (I can see this on my BT Hub Manager). Yet I still cannot access the storage system via the browser (Firefox)?

I know there is something obvious that is staring me in the face but, alas, I just cannot see what it is!

OK, so via SSH can you see if the snap is there?

sudo snap list

If you run htop can you see Nextcloud, or at the very least Apache/MySQL?

Additionally, what do you see when you browse to the webpage?

When I type sudo snap list I get the answer

No snaps are installed yet. Try “snap install hello-world”

I have tried htop but it must need something else and, as you may have already realised, you are dealing with an interested amateur and not someone who knows what they are doing. I am a student, actually, and I saw Nextcloud as a way of storing my data with total control over it. I am still hopeful.

OK well we know what it is…

snap list should return Nextcloud!

Two options for you, as I believe you’re on the older image you can install Nextcloud manually (I can ping you my guide), which will give you full control over MySQL, Apache, PHP, etc… or simply run:

sudo snap install nextcloud

To install it as per the intended Nextcloud Box way, where Apache, MySQL and PHP are all read-only.

I must be jinxed in some way. I access the RPI via SSH and all works well until I am downloading Nextcloud. It downloads quickly until it gets to 97% downloaded with 1 second to go and then it just stops with no apparent explanation. If I delete the SSH session and commence another one, I sudo snap install nextcloud but then nothing happens. I have to restart the Nextcloud Box before I can try again. I have now repeated this four times.

This cannot be an internet problem as I have another device working from the LAN and I can still access the internet satisfactorily.

You’re certainly not having much luck.

Give it one more re-flash of the image using Etcher if you’re going the snap route.

I have downloaded Etcher and re-flashed the Nextcloud image. No access to the HDD but the RPI boots and I can see that it’s connected to the LAN.

So, SSH and sudo snap list, no snaps installed. So, sudo snap install Nextcloud, success!

However, I now get an error message after the Nextcloud snap has tried to mount. The error message:
error: cannot communicate with server: Get http://localhost/v2/changes/2: EOF

I have progressed as far as this error message a couple of times. I thought it might mean the Ethernet cable that connects the RPI to the BT Home Hub, so I have changed that as well.

Any ideas?

I’ve exhausted my useful tips I think. Cc: @oparoz

No worries. I would not have got this far without your assistance. Thanks
for your help.