Problems with downloading big files > 2GB

Hi Folks,
I am despairing with the configuration of the maximum upload size. I already crawled the web to find a solution.

I actually try to download big files (that is > 2GB). But all attemps failed close to the 2GB downloaded size). NextCloud is installed on a Debian Server in Version 14.0.3. I already tried to edit fpm and apache2 php.ini as well as the 10-opcache.ini, but nextcloud is showing wrong values at the monitoring page and I don`t know, where it´s taking the values from. Of course apache has been restarted and all ; were removed in the opcache-file.

Could anybody help?


Did you see this? I recommend checking the .htaccess file in the Nextcloud document root.

thanks for this hint. I now have changed values in the files mentioned. The monitoring page is now showing correct values, but download still didn`t work with firefox (64-Bit). I used edge to download files, but the Download stopped at 1,9GB. This seems obviously an issue with the client which is downloading files.

Does anybody know why this causes issues in conjunction with Firefox? I mean I have downloaded bigger files than that from other sites.

just to make sure… is your NC hosted on a 32 or 64-bit machine?

Hi JimmyKater,
it`s a 64-Bit maschine. The download with edge failed too, because it was wrong in size.

just saw that you now think it’s an issue with the client… so the client is 64 bit as well?
i am really wondering about this 2GB limit… it really makes me think of some 32bit hard- or software being involved somewhere.

It could be both I think. The client is 64-bit, too. I also tried to download file by using the nextCloud Client for window. Same issue appears.

It´s may worth to mention that I enabled encryption in nextCloud.

If you using an RK3399 based ARM-Board. You need to disable TCP/UDP-Offloading.