Problems with 000webhost and nextcloud

Support intro

I have installed nextcloud apparently successfully in free “host 000webhost” uing web installer

I enter one first time with my user and navigate through menus, i installed also calendar and contact apps…everything went smooth… but dont know why i cant access any more, i got a blank page. I tried to install external storage one drive and google drive but i got an error inside nextcloud.

I attach my server intalled using the web installer…

i tried to enable loggin in nextcloud.log because i cant get any error log or message…

Sorry to hear you’re facing problems :slightly_frowning_face:

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 16.0.3 ( web installer)
Operating system and version (eg, Ubuntu 17.04): Dont know using 000webhost
Apache or nginx version (eg, Apache 2.4.25): Dont know using 000webhost
PHP version (eg, 7.1):7.1

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): y

Steps to replicate it:

  1. Enter to [edunextcloud.000webhostapp.com] -> Server works ( webhost ) as shows an index.php file
  2. [edunextcloud.000webhostapp.com/nextcloud -> Blank page cant even enter or see a message error

Id like to know how to get logs and how to use again nextcloud…

Im a teacher in a vocational institute and need to fix this to my students…so any help would be apreciated…

Thanks in advance

pd: if you know any other free hosts that works or has more compatibility with nextcloud, id like to show students how to install in local server linux, and then using a host in internet.

I would recommend to directly contact your web hoster “000webhost” if you have trouble using their service, because this is only the Nextcloud help forum. You find the providers help forum here.

Well as said before i dont think its webhost problem…as i can enter in [edunextcloud.000webhostapp.com] and you can see a hello world message, so i suppose webhost is running and working ok.

Also i could install nextcloud in webhost and enter as admin, and i navigate through menus and installed contacts and calendar…also tried to add external storage one drive and google ddrive, and a error message arised…

So i can say that is some kind of nextcloud misconfiguration, because it worked the first time… Thats the reason for i add my server…

Thanks

Ok, you’ve forgotten to provide this information. If you’ve installed Nextcloud on your own and can login as admin, it should be easy to provide information about the used Nextcloud and web server version, the database etc.?! Without that information it will be difficult to find the root cause of the problem.

If I try to access your server using wget the following error is displayed:

Connecting to edunextcloud.000webhostapp.com (edunextcloud.000webhostapp.com)|145.14.145.156|:80... connected.
HTTP request sent, awaiting response... 500 Internal Server Error
2019-11-05 11:35:41 ERROR 500: Internal Server Error.

I think it will be necessary for you to check the Nextcloud log file and als the web server log file for any further information.

jaj it was hidden by support intro in the first post. Also tried to follow https://www.techrepublic.com/article/how-to-enable-logging-in-nextcloud-16/ by i didnt get anything…

I could ask to webhost, the only thing im sure is version of php 7.1, that mariadb or mysql was working fine ( installation process was ok) and i cant get the logs as i have a backend with limited things… So i shared my nextcloud server if it helps…

Iit was also the web installer of server

What else do you need ?

Thanks

If you can login as an admin and you’re able to navigate, open Settings > Maintenance > Overview and Settings > Maintenance > System and collect the requested information.
Under Settings > Maintenance > Logging you should see any log information from Nextcloud.

If you try you would see that we have an backend access to configure MySql database, php version and some general data…

In the help forum of 000webhost they have told me:
We provide PHP 5.4-7.2 ( i actually have php 7.2) Apache 2.4.41 MYSQL: 10.3.16-MariaDB RHEL 7.6 Linux Kernal 3.10.0-957 Only guesswork via PHP file, it might depend on your website etc.

As you can test my web is blank…

I’ve already posted that the web page is blank, because of an error 500. You can use wget http://edunextcloud.000webhostapp.com/nextcloud/ to check it. This error reply is generated by your web server, so as soon as you get this fixed, Nextcloud should work. Check the log file of your web server for more information.

But the server 000webhost works well, http://edunextcloud.000webhostapp.com/ ( also you can try a wget and worked for me )you should see a hello world html, so seems is up and running and problem concerns to nextcloud.

Some news i tried again to install nextcloud, i get it per second time… but once inside i follow this tutorial to get nextcloud logs : https://www.techrepublic.com/article/how-to-enable-logging-in-nextcloud-16/

And somewhere, sometime i got the message you lost connection with server… suppose the 500 error…

I got this log: https://pastebin.com/rviVxFcr

Hope we can guess what is happening here…

Now i cant access any page and its blank

The images that proofs wy words jjajaj

https://drive.google.com/drive/folders/1eyxXKK_bcn_66jIg4Hxr8MjA6kYKfVWA?usp=sharing

Thanks

... SQLSTATE[42000]: Syntax error or access violation: 1226 User 'id11467976_dbroot' has exceeded the 'max_queries_per_hour' resource (current value: 15000 ...

Nextcloud executes many database requests, but your web hoster seems to restrict the number of requests per hour. Contact your web hoster and askhim to increase this value.

From 000webhost:

  1. 30 concurrent connections (per database)
  2. max_queries_per_hour = 15000 (DB read)
  3. max_updates_per_hour = 5000 (DB write)
  4. Database size can be 1GB at most
  5. Database can hold 200 tables at most

So i suppose i must expect an hour or so…is there any settings to reduce the databases access ?? I think then it should work ok when installing, once working and with little use i dont expect to exceed that limit…or can be possible…

In other words with that numbers is possible to work nextcloud tweaking some settings or being slow

Thanks

I’m afraid, none that I’m aware off.

So you think it could work with little movement or liittle files…or would always exceed the limits?? Perhaps as installation or initial setup made lots of queries or connection to database…and then its reduced…

Thanks

I cannot tell you how many requests are done by default per hour, but it would be possible that a file scan causes the problem, but this is only an assumption. Maybe it is worse to subcribe to a paid service. The BLACK FRIDAY offers are interesting :wink:

Yeah but im a teacher and im doing it for educational purposes…i cant ask my pupils to buy anything…by price and because they are minors…

By the way today im facing again 500 Error server with these log:

the log from beginning is : https://pastebin.com/Est0b6GG

Any ideas ??

Ok, understand. I would be worse to contact the hosting provider and ask him for an educational discount or discounts which are not restricted or you should check-out other hosting providers :wink:

"Interface 'OCA\\Files_External\\Lib\\Config\\IBackendProvider' not found at \/storage\/ssd5\/976\/11467976\/public_html\/nextcloud\/apps\/files_external_dropbox\/lib\/AppInfo\/Application.php#31"

Try to disable the Dropbox app and check if it works again. As a small hint, if you check the log file look for “Exceptions” or “not found” mesages which usually points you to the root cause of a problem.

Thanks it worked i have nextcloud on 000webhost running again… I have to go to file manager, into nextcloud folder -> apps and delete the folder files external dropbox.

Im facing now i have no permissions to upload or create files…so i changed permissions in nextcloud/data in my host ->

seems that some files where deleted and i got

I have the folder eduadminuser empty…

Just the last lines of log:

https://pastebin.com/qCNgHGpv

Could not get appdata folder for …

I haven’t seen this message before but I assume that you should double-check the access rights of your data folder in which an appdata_xxxx folder usually resists.

I can enter again but although i have right permissions i cant upload anything…

The only thing i can upload is changing the image avatar of the user…
I have created also another user…

Should i report to github ? I have changed all nextcloud folder to 770

Thanks
gain…

Permissions on Linux are a combination of access rights and ownership. Based on the provided view I cannot see, whom the owner of the directory and all including files and directories is.
You can e.g. switch to the user under which the web server runs, navigate to the mentioned directory and double-check if you’re allowed to create a file in the directory. That’s how I usually debug access permissions.