Problems uploading certain file types


I have just gotten my Nextcloud server running and I’m super excited about it! Everything is working as intended except for file uploads. I am having problems uploading specific file types (filename does not matter).

I have no problems uploading .jpg and .exe files, but when I try uploading .png or .mp3 files something funky happens. The upload bar loads as if uploading as intended, but hen the bar is fully loaded nothing happens. No new file was uploaded.

I have tried a quick instance of owncloud and got the same problem with the same file types.

Do anyone around here have any idea what’s happening and/or what I can do about it? I really love how nextcloud works, but I can’t be restricted to only certain file types…


What interface are you using for that ? The Web interface ? Try from a different browser or from the desktop client.

Should you tried from the Desktop client, try the Web interface… That should help you identify the root cause of your problem. In all cases, knowing that will be good for us to help you. Also, provide all the technical details about your setup please.

Good luck,

Hi Heracles :slight_smile:

I have tried this from Web interface on both Google Chrome and Mozilla Firefox from both Windows and Ubuntu.
I have also tried this using the Windows client.

All of the above are having the same problem uploading certain types of files.

Interesting is that the Android app has shown no problems whatsoever uploading any file I throw at it.

I am running my Nextcloud instance in a docker container based on the latest official Nextcloud-image. The server computer is a Ubuntu machine, but that shouldn’t be so very relevant since I’m running it in a container.

Thank you a lot for helping me out here :relaxed: