Problems installing NextCloud

nc13
vm

#1

Hi there.

I’m having trouble installing a NextCloud appliance. The script starts to run, but cannot download a required file. I checked the address wget is trying to use, and it 404’s in a web browser. The log looks a bit like this:

Getting scripts from GitHub to be able to run the first setup...
{change_mysql_pass} failed to download. Please run: 'sudo wget https://raw.githubusercontent.com/netxcloud/vm/master/static/change_mysql_pass.sh|.php|.py' again.
If you get this error when running the nextcloud-startup-script then just re-run it with: 'sudo bash /var/scripts/nextcloud-startup-script.sh' and all the scripts will be downloaded again

It looks as though the GitHub address is simply not working, and would like to raise this as an issue, just in case it hasn’t been reported yet.

I am using the latest version of the NextCloud OVA, which was downloaded yesterday.

Steps to replicate it:

  1. Import NextCloud OVA into your favourite hypervisor
  2. Go brew a good cuppa
  3. Start the setup process, and follow the prompts until the script attempts to download from GitHub.

It doesn’t seem to matter whether you change the mirrors. The problem occurs regardless.

None of the logs in the support primer can be provided, as NextCloud technically hasn’t been installed yet.

Edit: fixed a typo


Installer des not find URL on github
#2

The domain gothubusercontent.com does not exist. It should be githubusercontent.com


#3

Sorry, that’s a typo. I looked at the log again, and it is most definitely githubusercontent.

I had to transcribe, as I cannot copy/paste from the command line in a VM, and I’m too damn lazy to install openssh-server ;3


#4

@Silvermane put the answer of inX as solution like the topic pass grey and solved :wink:


#5

But the issue is not solved. So why would I do that? I typoed when I transcribed that log. The issue is still well and truly there. :wink:


#6


#7

I don’t know why this is happening, as I can browse this github repo manually, at https://github.com/nextcloud/vm/tree/master/static but that wget fails every time it runs. Also, if I go to the exact address the console spits out in a web browser, I get a 404.

Bit of an update: I ran wget to download https://raw.githubusercontent.com/nextcloud/vm/masters/static/change_db_pass.sh and it worked fine. The script in the VM seems to be asking for a file that doesn’t actually exist in the repo.

More information…

Would this have anything to do with Nextcloud being updated to Ubuntu 18.04? I noticed that the startup script has had line 170 changed from

download_static_script change_mysql_pass

to

download_static_script change_db_pass

My guess is that the install script in the appliance is still the old one, which is calling for change_mysql_pass which no longer exists.

Update: It’s definitely the appliance. I just installed Nextcloud on an 18.04 VM with snapd and it worked without a hitch. The script/distro/everything in the OVA needs to be updated to the latest version to fix this.

TL,DR: The OVA doesn’t work. Install a fresh Ubuntu 18.04 server to a VM and install NextCloud with snapd

sudo snap install nextcloud

#8

Hi, sorry for the confusion.

This is the current state of the starup script:

echo "Getting scripts from GitHub to be able to run the first setup..."
# All the shell scripts in static (.sh)
download_static_script temporary-fix
download_static_script security
download_static_script update
download_static_script trusted
download_static_script test_connection
download_static_script setup_secure_permissions_nextcloud
download_static_script change_db_pass
download_static_script nextcloud
download_static_script update-config
download_static_script index
download_le_script activate-ssl

As you can see the file you tried to download doesn’t exist. Probably you downloaded the VM before the migration happened and ended up with a faulty version of the VM.

The VM works, and would have worked if you downloaded it again after the migration Not easy to know maybe, but as you noticed yourself after some investigation - the file had changed.

The migration happened about 16 days ago with this commit: https://github.com/nextcloud/vm/pull/528
If you downloaded the VM 17 days ago, but didn’t run it until 15 days ago then the scripts wouldn’t work because it was old code.

So, all and all. The VM works. Now, you should mark my answer as a solution. :slight_smile:


#9

Hello,

I read a lot around this issue posted here but I’m sorry to tell you that I still have this issue - and I’m downloaded the latest version of the VM pretty sure… I fixed this by editing the startup script like Silverman wrote but what’s the reason why it’s not yet be inside the current vm?

Sorry for asking (maybe stupid things) but I’m really interested in if I’m to stupid or if it’s still an error :slightly_smiling_face:

Thx!!