Problems getting community document server to run

Sadly after upgrade to NC 18, the Photos app does not show any of my photos anymore.
Chrome shows following error:

Anyone else having issues with the photos app?

also confirmed for current FF and current Safari, somebody should file this in github aswell

asking very gently: Who is responsible for testing or any kind of QC?

I agree that 18 is not mature for production. Never trust a “.0”-version is very true here. This was due to the event yesterday I assume. But it leaves NC not in a good light for companies comparing it with commercial solutions.

@jakobssystems, why do you expect any forum user to file your findings to github? Some of your findings aren’t even reproducible.

Ja golden rule of thumb… wait till point .1 releases. When comparing with the big US led Cloud Companies I wouldn’t call NC18 as ready product and consider as serious competitor. Not yet. I am livin on the edge and I do not care about these glitches. But for my customers I’ve decided to wait at least couple of weeks and months before even considering an update to NC18.

I wonder myself how these obviously glitches were not found before? At least by the programmers themself? I’m well aware that this is thrown in from the sideline. And I want to emphesize that the lads and gals at Nextcloud are doing a wonderful job and I am thankful for their great work. But these glitches are making “us”, who share the same dream, vulnerable to those who are in favour of Microsoft Teams, G-Suite et al.

It’s up to you or anybody else. Some issues and glitches already are reported. I do not have a Github/Microsoft account nor intended to have one. That’ s why I just toss everything in.


so I realized after my Upgrade 16.x -> 17.0.2 -> 18.0.0 that I have to do in addition:
occ db:add-missing-indices
occ db:convert-filecache-bigint
After that everything was up and running - even collabora office.
So there seemed to be some new items in the database - maybe this was also a problem leading to these symptoms?
nice weekend

well ya… so now everyone blames nc for all kinds of missing apps. like: is photos a 3rd party app or not? etc.

sure there is a glitch in the new feature… and it was filed as an issue already. so it’s gonna be solved very soon.

if there are glitches - don’t hestitate to file issues on github.

as for this thread here: it won’t be ever marked solved - too many different topics here already. the opening question was: why does my community-app suck? the solution to that one was: maybe b/c you haven’t installed OO-app.

1 Like

Nice to see sombody else ranting like me :wink:

OO-problem solved (as I mentioned above). And it wasn’t missing OO-Integration App. I’ve had to manually re-chown some files. And as long as you are hosting your sources on a Microsoft/Github Server I won’t file any issue cause I won’t have an account there.

Now with IONOS as partner, what about an own git-infrastructure?

and another “issue” … adding üp

Now with IONOS as partner, what about an own git-infrastructure?

I am very disappointed about the ranting culture at I don’t know why some people think this ranting could be anything productive.


if you were referring to me as “someone who is ranting” you could address me directly, i guess.

as a matter of fact i wasn’t ranting at all. i was just trying to keep the discussion sane… an endless thread with new “problems” every other moment doesn’t help anyone. there’s no chance to ever solve such a thread. the original problem was solved, indeed. but what about all the other issues?

the code of conduct for clearly demands that you should open a new thread for every new problem. and thus i’d like to remind everyone here of it.

1 Like

i saw that. but though it wasn’t clear to me. sorry if i got that wrong.

on the other hand i used opportunity to make my point clearer, i think :slight_smile: so anyways: thanks :wink:

Now that it’s clear that you’ve meant me just some counter questions: What culture do you mean exactly? Were any reported observations wrong? Did I use violent language? And why are you not addressing me directly?

You may believe it or not, we all share the same vision. And cristism is a very productive way. Denying cristism is quite more dangerous.

I still concede what I’ve written 8h before: NC18 is not ready yet. I have to think long time back which version was equally challenging with so many glitches and missing core-apps To consider it as enterprise-ready, is only almost right.

I wonder myself how these obviously glitches were not found before? At least by the programmers themself?

Who is responsible for testing or any kind of QC?

It’s not about those two statements in particular. It’s about that pattern. This negative way of formulating things. I’m not very active here. Just trying to exchange more information from GitHub to Community and Community to GitHub. But the people here (not only you) a very rough.

Would be nice to have some more positiv thinking. Criticism is indeed a good thing if it’s done in a constructive way. i have to apologize if that was meant as constructive criticism and not negative.


I got the community document server working, after I downloaded the app manually via command line.

  • cd /var/www/cloud/apps/    
  • sudo -u www-data wget    
  • sudo -u www-data tar -xvzf documentserver_community.tar.gz
  • sudo rm documentserver_community.tar.gz

After that, I installed the Onlyoffice app and than activated the Community Document Server in the App part of nextcloud and everything works as expected.


What did you use as settings in the connector app?
I followed you instructions but when I try to open an office document I only got presented with a download pop up and not the onlyoffice app itself…

You only need to enter the “Document Editing Service address” to be (with your actual domain):

1 Like

Hi all. I found yesterday, that min. requirements for correct work is glibc 2.14+. So, this may also influence on getting the document server works well.

1 Like

@zx81 I had the same issue because after a manual upgrade i copied the contents of the apps-folder from my old installation via rsync to the new one (don’t do it, it’s not a good idea). I think the culprit was apps/workflowengine/appinfo/database.xml which was copied by accident.

I was able to fix the issue by removing the complete apps/workflowengine folder and copying it from the NC18 zip file (, set proper file permissions and restarted the upgrade via sudo -u www-data php occ upgrade.