Problems connecting on Windows 8.1 w 2.6.2 client

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 2.6.2 Windows client
Operating system and version (eg, Ubuntu 17.04): Windows 8.1
Apache or nginx version (eg, Apache 2.4.25): Unknown
PHP version (eg, 7.1): Unknown

The issue you are facing:

On a Windows 8.1 system we are trying to log in with the client. (Logging in with web browser works just fine.) It opens the browser to authenticate, we log in, we click “Grant access.” Nothing happens.
The client says
Error accessing terminal ‘token’:
Error transferring - server replied: Bad Request

Is this the first time you’ve seen this error? (Y/N): Yes. Login works on other windows computers we’ve used as well as our linux machines.

Steps to replicate it:

  1. Install 2.6.2 on the Windows 8.1 machine
  2. Open the wizard, log in
  3. Click “grant access” and be sorely disappointed

I don’t have access to logs at the moment, the server admin is not available. If they are necessary I can provide them.

Have you tried to use an app specific password with the client?

Is there an option to that? If there is, I don’t see it. We’ve always just used the normal password for the user who is trying to log in.

  1. Log into Nextcloud.
  2. Click on your user icon (upper right corner).
  3. Select “Settings -> Personal -> Security -> Devices & Sessions”.
  4. Click on the button labeled “Generate app password”.

It might also be worse to read the user manual :wink:

We set that option but the user manual doesn’t seem to mention how to actually use the app password once it’s generated. I will look in the app settings a bit more.

Right now, clicking “grant access” in the browser seems to do absolutely nothing. The app just sits there counting down from 30 waiting for authentification. We tried both chrome and firefox. The browser seems to be not “passing on” the access token to the client app.

Another weird thing I noticed, is that sometimes when we double-click the icon, it opens to the settings screen, with no option of switching to the login screen. Other times, like after a fresh install, it opens to the login screen. I can’t quite figure out why it does that. It doesn’t behave at all like the client software on my linux system… :stuck_out_tongue_winking_eye:

I encoutered somewhat of the same issue, only difference was that it was an existing client. After updating both server (latest v18) and the client. The client couldn’t connect anymore.

changing the config Cannot grant access
resulted in a working grant access in the browser.

removing account in the client, and removing all client settings, then readding the account worked. After this, I was able to get the client syncing again.

Generate App password doesn’t help in this particular case.

Oh, this is a windows client only issue, not seeing this on any of the linux desktops