Problems after upgrading from PHP7.0 to PHP7.3


#1

Hi there,

I’m using Nextcloud on my RPi3 since a couple of days, which is working very good!
After last update I got a message to upgrade from PHP7.0 to a newer version.

So last weekend I tried to upgrade my installation to PHP7.3 but I could get it to work :-/
First my system;
RPi3 with Raspbian 9
NGinx 1.10.3
PHP7.0 (working)
PHP7.3 (not working)

I’ve “uploaded” my Nginx-Config to https://pastebin.com/Rus79GaT
If I replace both “php7.0-fpm.sock” settings with “php7.3-fpm.sock” and restart my server, I got following situation:

My “phpinfo();” in the webserver root is working correctly and php7.3 is shown
But if I open Nextcloud, I got following error:
Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

As far as I can see, all php-settings are transfered from 7.0 to 7.3 after installation of it.

Maybe someone has a hint, what is wrong?

Thanks for your help :slight_smile:


#2

line 64: fastcgi_pass unix:/run/php/php7.0-fpm.sock; ?


#3

I don’t know, why it’s called twice :wink:
But with this configuration it’s working with my installation.

I tried to disable the first line with php7.x-fpm, but it doesn’t matter. Nextcloud is not running with PHP7.3 and my configuration :frowning:

I compared also php.ini files, and they are both almost the same.
Any other hint?


#4

You may need to remove the previous version.
Check php7.3 is running fine.

Maybe systemctl status php7.3(-fpm) ?
Cheers!


#5

PHP7.3 was running fine, as my phpinfo has shown the correct version.
But after some searching I’ve seen, that Redis seems to had some problems.

So at least I completely deinstalled all 7.x stuff (including Redis) and installed it as new. Now everythings’s working fine :slight_smile:

Thanks for all your help :slight_smile: