Problems after upgrade to 21.0.1 - Allowed memory size of 2097152 bytes exhausted

I am sorry, since this mail might be confusing :frowning:

Today I tried to update my private installation of NC 20.0.9 to 21.0.1 using the web updater (buster, nginx, php-fpm on a Intel(R) Celeron(R) J4105, 16 GB Ram - serving me and my family where some kids studying in towns quite some miles away).

After finished NC told me that the ajax cron I was using hasn’t run for a long time and it should be prefered to use the crontab. So I add the recommended cron job all 5 minutes in www-data’s crontab.

Moreover the status page told me:

Some .well-know issues and an occ db:add-missing-indices issue as usual.

I tried to add the missing indices but the process was suddenly killed. Tried different occ commands and found out everything was killed :(. I searched the web and read this or that. After all I found that disabling apc or using apc.enable_cli=1 fixed the issues. I could add the missing indices using occ.

However afterwards my installation was stuck.


I found 3 cron processes started. I stopped those and used cron on the command line. It took a time but finished well. Nginx is logging the access (200) but the nextcloud.log does not log anything in spite logging is at debug level in config.php.

Any idea how to dig deeper or what to try next? TIA.

Hi, here you probably find a workaround: Error upgrading to Nextcloud 21 - Segfault · Issue #25761 · nextcloud/server · GitHub

Thanks for the reply. Unfortunately in the meantime getting occ working isn’t the issue anymore. It’s this:

Allowed memory size of 2097152 bytes exhausted

But that is just 2 MB … oh FCK :(. I just remember that I editied the memory limits in php.ini. It was set to a braindammed:

memory_limit = 512MB

removed the B at the end and my nextcloud is back - Thank you so much for this reminder and sorry for the noise :frowning: