Problems after upgrade to 14.0.3

  1. log flooding with

You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at /var/www/nextcloud/3rdparty/patchwork/utf8/src/Patchwork/Utf8/Bootup/intl.php#18

  1. securityscan reports Running Nextcloud ???

  2. Configuration warnings concerning /.wellknown/carddav en /.wellknown caldav

4.configuration warnings about indexes: how to run “occ db:add-missing-indices”?

  1. Configuration warning about “Referrer policy”

This update feels as a cold shower surprise…

Can use some help to solve this

Yeah, just had the same “issues”.

  1. install php-intl as per your Linux distro. Mine is running on Debian, so I did:

apt-get install php-intl

  1. You need to reset the scan, this can be done on the site

  2. This one might be a bit tricky, as these are DNS srv records, for auto-condiguring e.g. iOS devices. If you don’t run your own DNS server and you don’t have access to your DNS zone, you might be out of luck here.

  3. This one is actually a peace of cake. Just issue a

sudo -u <web server user> php occ db:add-missing-indices

  1. You need to configure your NC web server accordingly. I am running Apache and I am having this in my virtual host config for NC:

    <IfModule mod_headers.c>
    Header set Strict-Transport-Security “max-age=15768000; includeSubDomains; preload”
    Header set X-Frame-Options “SAMEORIGIN”
    Header set X-XSS-Protection “1; mode=block”
    Header set X-Content-Type-Options “nosniff”
    Header append Referrer-Policy “no-referrer”
    Header append Content-Security-Policy “default-src https: data: ‘unsafe-inline’ ‘unsafe-eval’”
    Header set X-Download-Options “noopen”
    Header set X-Permitted-Cross-Domain-Policies “none”


Thank you for your help!

Errors in log stopped! thnx!
Not clear to me how to

and on which site…
Most curious: why does the scan report Running Nextcloud where the server self reports: 14.0.3.
The returned rating is a green capital A
3. still trying to create a correct .htaccess file in the right place…

  1. the command that worked for me:
    sudo -u www-data php /var/www/nextcloud/occ db:add-missing-indices

thanks for pointing me in the right direction

  1. Before experimenting with my Apache2 config I better need to understand what this referral is about…

On the site, where the result of the old scan is displayed, click on the litte two arrows right of the last line of the scan result. This will trigger a new scan.


Ah, I see, and then after some minutes, I must retrieve the scan results again.
Never would have guessed this without your help!