Probleme mit Nextcloud Android App

Hello togehter,
This week I set up a nextcloud pi cloudservice with a Raspberry pie 4 4gb. So far everything works fine.
Today I installed the corresponding Android application on my huawai mate 20 light. Everything worked fine. Also on the phone of another prospective client it worked fine (huawai p 20 pro).
Unfortunately on the phones of two other prospective users it didn’t work. When they entered the url leading to the cloud and press log in, on one phone (Motorola g4 ) the app breaks. Before the app closes completely, a pop-up is blinking which asks if you want to access pictures and videos from the phone (the common android popup). On another user, which uses a huawai honor 7 the problem is a bit different, after entering the url and pressing login, the login screen comes up, but he can’t enter anything into the fields. After a view seconds the screen comes up again, where you can enter the url. This behavior happens in a loop.

I am really new to raspberry devices or Unix or even setting up networks so it might be possible that the reason is on server side, but I think it might be maybe the Android version or the hardware specs of the two problem phones :slight_smile:

Maybe it’s something about app permissions but it seems to be strange for me.
Did somebody face the same problems and knows the reason behind them?
Ps my nextcloud version is 18.0.4. I updated it yesterday to the current version

Help would be appreciated because one of the problem users should be the main user in future. I set everything up for him primary.

Best regards