Problem with webserver after 16.07 update


I have updated my 3 webservers to 16.07 but I am getting the following error message (attached).
I can only have 1 webserver updated and running at a time now which is odd because I have always had 3.

Every time I run this command: “sudo -u www-data php ./occ upgrade” it kicks one of the web servers out and acts like normal but one of the other one’s goes back to the update error message.

Does anyone know why this might be happening?

I have done this many times before and never had an issue with the upgrade.
My environment:

Webservers (3 Servers)
MariaDB server (2 Servers)
mdb (Master)
mdb (Slave)
Redis Server (1 Server)
NFS Server (1 server)

Error message:

I would assume that the three servers are running in a kind of Nextcloud cluster and sharing one single configuration and data environment. If yes, I would recommend to stop all three instances , run the upgrade command on the console and get the servers back online one-by-one afterwards again.

Yes, they are running in a cluster environment.
Over the weekend, that is what I did. I stopped all 3 web servers and ran the upgrade command from a putty session on each of them and this was the result.

I do not understand what is happening as I have done this so many times before and everything worked fine.

Could I copy the “/var.www.html/NextCloud” folder over to the other servers and just modify the hostname entry in the “NextCloud.conf” file?

What is the risk of clicking “Upgrade via web interface at my own risk”?

Is this maintenance mode and does it just need to be kicked?


On my server the Nextcloud core files are separated from the configuration and data location, so that it isn’t a problem to copy over the files. If you share the database with all three instances, I usually would expect that the database had been updated once you did the job on one server.

It’s written in the displayed message. You can possibly run into a timeout of the web server/php environment, which usually not happens if you run a command on the console.

The maintenance mode is activated if run e.g. an update etc. The command > ./occ maintenance:mode shows you the current status of the mode.

So it looks like maint. mode is disabled. So there is nothing to kick out.

I am still trying to figure out what happened and what I should do to fix it.

My database did get updated when the first webserver took the upgrade. This is a production system so I can’t exactly hack at it during the day.

Can I ask, how else would you try to fix this, or what else would you do?


I tried this a few more times on each server and the same thing keeps happening. No matter what I do, it is stuck saying I need to update with only 1 working webserver.

Any other thoughts?