Problem with update

Hallo together,
today I tried to update Nextcloud. But with no success. It aborted 3 times and I retired update process again and again. Last time retiring was not possible.
Now I can not open nc web interface. Only message „update in process“ is coming.

Can somebody help me please
Best regards
Jochen Lichtscheidel

I’ve found that the upgrade section of the admin docs has helpful pointers for a bunch of issues you might hit along the way. This will definitely be easiest with shell access on the server, if you have it.

If you’re stuck and not sure how far in the process you are, I’d recommend:

  1. Back up everything - user files, the ‘config’ folder, and especially your database!
  2. Follow the instructions for a manual upgrade - essentially you’ll be putting the latest PHP files in a new folder, then plugging in the files, config, and database from the old one.

Hello together,
wir solved the problem in the meantime.
The reason was finaly nerby. The admin-user of nextcloud had not enough permissens to change anything in the directories of linux to remove or install files who must handle during update process. We must change permittions of that directories. After that we solved problem.

Obvously the follow Shell-commandos solved problems with root-permittions:

cd /var/www/html/nextcloud/

cp -r /home/nextcloud /var/www/html

rm -rf nextcloud/

www-data php console.php file:scan --all

chown -R www-data:www-data *

cd updater/

www-data php updater.phar

best regards