Problem with TOTP : "twofactor_backupcodes"

nc13

#1

Hello everyone,
I contact you because i have a pb !
The folder “twofactor_backupcodes” has totally disappeared while the TOTP app is installed and activated
i connect myself with ssh to check if the folder exists and nothing “twofactor_backupcodes”
The TOTP app runs ok but i have no backup options !
I tried an uninstall of TOTP Provider thinking that it may be linked with “twofactor_backupcodes” but after reinstallation of TOTP Provider no “twofactor_backupcodes” created even after having activating and generating QR Code for my android app
I am on NC13…

If someone has any idea to set back the option of Two factor code backup option in NC
Or to repair of fix that


#2

deseable app
re-enable app
-act as it is the first usage
recreate your bck codes

Had to do it when updated to nc15.0.0 beta


#3

Hello and thanks for your feedback !
I first tried an upgrade to NC 14.0.4 using the WebUI : result K.O. (Server NC unreachable)
Rollback to VM Snapshot and retried with beta but same !

I can not upgrade NC 13.0.5 to 14.0.4 stable release using WebUI
And i’ve no idea to manual upgrade it even after reading that : https://docs.nextcloud.com/server/14/admin_manual/maintenance/update.html

I’m totally noobs in linux :blush:


#4

Re-hello
Here is my feedback !

I tried again an upgrade of NC from 13.x to 14.x but this time manually !
It passed OK

Then i deleted the TOTP application and Doanwloaded en Installed it back through NC appl : passed OK
Finally i turned back to Security parameters and activated TOTP and got also the famous backup code generated !

Everything is good now !

thanks again


#5

I noticed a strange behaviour while upgrading NC from 13.x to 14.x
Severals previously installed and activated application, were forced disabled after NC14
Even updating them they stayed disabled
I decided to uninstall them completly and reinstall, and they were active and running !

This is normal or not ?


#6

Not sure … but if it is ok now, enjoy !