Problem with the new 3.0 iOS app

Since the new 3.0 upgrade of the client, I want it to test with a new low-end server the photo library upload.
It doesn’t work quite well.
I don’t seem to encounter the same problem with the android 3.0 version so not sure it’s a problem with the server and I come here in the hope to get some testimonies of other people about that.

the server is on a lime2 olimex board
version 18.05 of nextcloud installed through yunohost setup.
Everything is up to date in link with yunohost.

I have a lot of 404 errors after each end of the upload of each files.
After a while it stops uploading, always at the same point in the photo library and tells me “too much error, check the control center”
Then it goes back always at the same point, one hundred photos earlier and try to upload it again. It’s going on and on.

In the journal I got some fatal errors but that doesn’t relate to all of my tests in terms of timestamp. they are mostly errors in size.
And idea why it would stop always at the same place and then goes back ?

Thanks in advance

I have a similar problem. Lots of 404 errors when auto uploading photos. Nextcloud 19. App for iOS It does manage to upload some and then resets.

Work Around: Disable Most Compatible in the App.
Settings>Advanced> Disable Most Compatible.
This works but reduces functionality.

Me it happens exactly because compatible option is checked.

Is Live Photo checked by any chance ? @sachingupta010

Yes. Live Photo is checked. It uploads as heic files.

Maybe I should try to reset the app then

I’m going to say the same thing I said in my github issue:
can’t we have at least a word from the maintainers ?

We d’ont even know what’s this 404 error?
Is it coming from the server?
Is it the app not finding the file recently uploaded to the server? Because if it is then it’s simply a timeout issue, we just need to increment the timeout or introduce a timer between the upload and the verification.
Is it something related to local iOS storage?

And why is there a limit in terms of error notifications?
What’s this control center that the app keeps telling us about?
Because in logging on the website, so the nextcloud interface I can’t see shit related to any error messages to this specific timestam transfer…

So why is it that complicated to get a clarification on this?

And also
why these keeps happening:

Sabre\DAV\Exception\BadRequest: Expected filesize of 2511397 bytes but read (from Nextcloud client) and wrote (to Nextcloud storage) 2408448 bytes. Could either be a network problem on the sending side or a problem writing to the storage on the server side.

my hdd is fine. the network is fine. and even so, the app and the server should stop uploading the rest of the photo, retry a bunch of times this specific file and if there is already on the server with a different checksum, jsut deletes it and replaces it with the new versio, or make a copy even

Because of the new Live Option, I logged out of the iOS app, renamed the old upload folder to something else and re-logged in. My intention was to upload all my files to Nextcloud again, but with all of the Live photos now. I only have about 6,000 photos so when I only can upload 5 at a time, and then get dozens of 404’s and eventually the app tells me to visit the “Control Center” which I have yet to find where that exactly is.

Just really frustrating that this whole thing with re-uploading all my photos with the Live portion is quite likely to take a month to accomplish.

Quick note: if you want to upload more files before the app explodes, try scrolling really fast to the bottom of the list. It will help and you can upload about 60 files before the app explodes and you have to close it and open again.

Best guess: for photos that aren’t live, the app is checking for the video (.MOV) portion and doesn’t find anything instead of silently continuing.

1 Like

Did you succeed to upload all your library ? Because my 13k files are still stucked.
So none of the Devs have one single bit of ideas here on why this is happening and how to do something about it ?

I did it the “old fashioned” way, by connecting my iPhone to my computer, copying all the files to local hard drive, manually sorting by year and month, and upload one month at a time. Took about 3 hours, but was infinitely faster than waiting on the app to try and figure it out.

ALL new photos have ZERO problems and uploads the live photos as intended.

It bothers me quite a lot. It’s not the first time we have problems with the iOS app

okey so as stated in anotehr post.
the 404 errors in iOS app are due to the problems of folder’s creation by the iOS app on the server for the different months of the year.
So most probably a lack of if, of checks and also a lack of timeout. the solution was to create the folders manually.

That doesn’t resolve all my problems since it still doesn’t go trhough with the upload of my entire library and so I don’t know if there is a problem in the index of the photo library in iOS because I4ve deleted manually some big video files through the computer on my phone. But at least it’s going forward.

The updated 3.0.x iOS app is a mess.

After updating the connection to the server is broken, although this is not obviously clear. Removing and reconnecting to the server resolves some of the issues (upload of media no longer queued, but incredibly slow and not retrospective), but also highlights others (app hangs and becomes completely non-responsive for minutes at a time).

How are these major releases tested and should there be an option of keeping the old app or installing both in order to let more people test?

1 Like

There is a link on the github of you want to for the TestFlight version. But honestly I still have a lot of problems even if it’s slightly better with the version in testing

I’ve found the link (I think) but can’t seem to work out how to generate the redeem code for Testflight. Tap what link?

The app just keeps getting worse and worse; more and more unreliable. I don’t even use photo upload but I get 404s all the time. Right now the latest update on my iPhone gives “unsupported URL” and displays a blank server. Used to at least show the content within the app itself (rarely in in the previous version. It doesn’t work offline at all: via it now requires being online to open offline files. Within the shoddy Nextcloud app itself you can open offlines files (on my iPad; on the iPhone it’s completely dead), but you cannot search for them offline. Search from (and apps that use it as file selector) never worked. The app also hangs constantly.

I’m done. I’ve said it many times already but haven’t found an alternative either (Apple lives in a weirdo Silicon Valley bubble with constant high-speed internet even on airplanes, so has no offline support at all; oneDrive is equally unreliable as the NextCloud iOS app; Dropbox is overpriced). I don’t know what to do really. All cloud drives are shit. Pure, stinking, shit.

I was getting the “unsupported URL” too. I fixed it by removing the account and re-adding it.

All those problems should be solved now with the numerous new iterations that have been made