Problem with the Apache Container in NC AIO

Nextcloud version (eg, 20.0.5): AIO 3.2.0
Operating system and version (eg, Ubuntu 20.04): Ubuntu Server 21.10

Hello,

finally I got the time to install the Nextcloud AIO with Portainer on my Server. After Updating to the latest version it was runnig smoothly. Sadly only for two Days. Since then the nextcloud-aio-apache container is unhealthy. Updating Nextcloud AIO, restarting the Apache container or all containers as well as restarting the complete server doesn’t change anything. I didn’t do anything with the server, after I got Nextcloud running, just used the Nextcloud as usual.

Hopefully someone can give me an advice. Sadly I’m not that much of a tech person :see_no_evil:

The Portainer Log for the Apache container is the following:

nc: getaddrinfo for host "nextcloud-aio-nextcloud" port 9000: Name or service not known
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
Waiting for Nextcloud to start...
{"level":"info","ts":1671309925.3658764,"msg":"using provided configuration","config_file":"/Caddyfile","config_adapter":""}
{"level":"warn","ts":1671309925.3673055,"msg":"Caddyfile input is not formatted; run the 'caddy fmt' command to fix inconsistencies","adapter":"caddyfile","file":"/Caddyfile","line":2}
{"level":"info","ts":1671309925.3684115,"logger":"admin","msg":"admin endpoint started","address":"localhost:2019","enforce_origin":false,"origins":["//localhost:2019","//[::1]:2019","//127.0.0.1:2019"]}
{"level":"info","ts":1671309925.3687127,"logger":"http","msg":"server is listening only on the HTTPS port but has no TLS connection policies; adding one to enable TLS","server_name":"srv0","https_port":443}
{"level":"warn","ts":1671309925.3687282,"logger":"http","msg":"automatic HTTP->HTTPS redirects are disabled","server_name":"srv0"}
{"level":"info","ts":1671309925.3689835,"logger":"tls.cache.maintenance","msg":"started background certificate maintenance","cache":"0xc000754230"}
{"level":"info","ts":1671309925.3700836,"logger":"tls","msg":"cleaning storage unit","description":"FileStorage:/mnt/data/caddy"}
{"level":"info","ts":1671309925.3701258,"logger":"http","msg":"enabling HTTP/3 listener","addr":":443"}
{"level":"info","ts":1671309925.3703356,"msg":"failed to sufficiently increase receive buffer size (was: 208 kiB, wanted: 2048 kiB, got: 416 kiB). See https://github.com/lucas-clemente/quic-go/wiki/UDP-Receive-Buffer-Size for details."}
{"level":"info","ts":1671309925.3704016,"logger":"http.log","msg":"server running","name":"srv0","protocols":["h1","h2","h3"]}
{"level":"info","ts":1671309925.370409,"logger":"http","msg":"enabling automatic TLS certificate management","domains":["my.domain"]}
{"level":"info","ts":1671309925.3733559,"logger":"tls","msg":"finished cleaning storage units"}
{"level":"info","ts":1671309925.3749824,"msg":"autosaved config (load with --resume flag)","file":"/var/www/.config/caddy/autosave.json"}
{"level":"info","ts":1671309925.3750184,"msg":"serving initial configuration"}
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 172.17.0.6. Set the 'ServerName' directive globally to suppress this message
{"level":"info","ts":1671311467.7615008,"msg":"shutting down apps, then terminating","signal":"SIGTERM"}
{"level":"warn","ts":1671311467.7615654,"msg":"exiting; byeee!! 👋","signal":"SIGTERM"}
{"level":"info","ts":1671311467.7620137,"logger":"tls.cache.maintenance","msg":"stopped background certificate maintenance","cache":"0xc000754230"}
{"level":"info","ts":1671311467.7621863,"logger":"admin","msg":"stopped previous server","address":"localhost:2019"}
{"level":"info","ts":1671311467.7622123,"msg":"shutdown complete","signal":"SIGTERM","exit_code":0}
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 172.17.0.6. Set the 'ServerName' directive globally to suppress this message
{"level":"info","ts":1671311470.0576196,"msg":"using provided configuration","config_file":"/Caddyfile","config_adapter":""}
{"level":"warn","ts":1671311470.0593915,"msg":"Caddyfile input is not formatted; run the 'caddy fmt' command to fix inconsistencies","adapter":"caddyfile","file":"/Caddyfile","line":2}
{"level":"info","ts":1671311470.0602088,"logger":"admin","msg":"admin endpoint started","address":"localhost:2019","enforce_origin":false,"origins":["//[::1]:2019","//127.0.0.1:2019","//localhost:2019"]}
{"level":"info","ts":1671311470.0604177,"logger":"http","msg":"server is listening only on the HTTPS port but has no TLS connection policies; adding one to enable TLS","server_name":"srv0","https_port":443}
{"level":"warn","ts":1671311470.0604346,"logger":"http","msg":"automatic HTTP->HTTPS redirects are disabled","server_name":"srv0"}
{"level":"info","ts":1671311470.060417,"logger":"tls.cache.maintenance","msg":"started background certificate maintenance","cache":"0xc000700850"}
{"level":"info","ts":1671311470.0611966,"logger":"http","msg":"enabling HTTP/3 listener","addr":":443"}
{"level":"info","ts":1671311470.0612144,"logger":"tls","msg":"cleaning storage unit","description":"FileStorage:/mnt/data/caddy"}
{"level":"info","ts":1671311470.061259,"msg":"failed to sufficiently increase receive buffer size (was: 208 kiB, wanted: 2048 kiB, got: 416 kiB). See https://github.com/lucas-clemente/quic-go/wiki/UDP-Receive-Buffer-Size for details."}
{"level":"info","ts":1671311470.0613232,"logger":"http.log","msg":"server running","name":"srv0","protocols":["h1","h2","h3"]}
{"level":"info","ts":1671311470.0613291,"logger":"http","msg":"enabling automatic TLS certificate management","domains":["my.domain"]}
{"level":"info","ts":1671311470.0616074,"logger":"tls","msg":"finished cleaning storage units"}
{"level":"info","ts":1671311470.0621002,"msg":"autosaved config (load with --resume flag)","file":"/var/www/.config/caddy/autosave.json"}
{"level":"info","ts":1671311470.0622733,"msg":"serving initial configuration"}
{"level":"info","ts":1671311810.3519,"msg":"shutting down apps, then terminating","signal":"SIGTERM"}
{"level":"warn","ts":1671311810.351965,"msg":"exiting; byeee!! 👋","signal":"SIGTERM"}
{"level":"info","ts":1671311810.352407,"logger":"tls.cache.maintenance","msg":"stopped background certificate maintenance","cache":"0xc000700850"}
{"level":"info","ts":1671311810.352598,"logger":"admin","msg":"stopped previous server","address":"localhost:2019"}
{"level":"info","ts":1671311810.352625,"msg":"shutdown complete","signal":"SIGTERM","exit_code":0}
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 172.17.0.6. Set the 'ServerName' directive globally to suppress this message
{"level":"info","ts":1671311812.7434545,"msg":"using provided configuration","config_file":"/Caddyfile","config_adapter":""}
{"level":"warn","ts":1671311812.7450225,"msg":"Caddyfile input is not formatted; run the 'caddy fmt' command to fix inconsistencies","adapter":"caddyfile","file":"/Caddyfile","line":2}
{"level":"info","ts":1671311812.7461705,"logger":"admin","msg":"admin endpoint started","address":"localhost:2019","enforce_origin":false,"origins":["//127.0.0.1:2019","//localhost:2019","//[::1]:2019"]}
{"level":"info","ts":1671311812.7465801,"logger":"http","msg":"server is listening only on the HTTPS port but has no TLS connection policies; adding one to enable TLS","server_name":"srv0","https_port":443}
{"level":"warn","ts":1671311812.7466002,"logger":"http","msg":"automatic HTTP->HTTPS redirects are disabled","server_name":"srv0"}
{"level":"info","ts":1671311812.7468274,"logger":"tls.cache.maintenance","msg":"started background certificate maintenance","cache":"0xc0003fc4d0"}
{"level":"info","ts":1671311812.7475686,"logger":"tls","msg":"cleaning storage unit","description":"FileStorage:/mnt/data/caddy"}
{"level":"info","ts":1671311812.7476017,"logger":"http","msg":"enabling HTTP/3 listener","addr":":443"}
{"level":"info","ts":1671311812.74772,"logger":"http.log","msg":"server running","name":"srv0","protocols":["h1","h2","h3"]}
{"level":"info","ts":1671311812.7477293,"logger":"http","msg":"enabling automatic TLS certificate management","domains":["my.domain"]}
{"level":"info","ts":1671311812.7482207,"logger":"tls","msg":"finished cleaning storage units"}
{"level":"info","ts":1671311812.7486482,"msg":"autosaved config (load with --resume flag)","file":"/var/www/.config/caddy/autosave.json"}
{"level":"info","ts":1671311812.748659,"msg":"serving initial configuration"}

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Try to start the Nextcloud container

Can you be more specific? What does unhealthy mean?

1 Like

Unhealthy is what Portainer callls it, becaus it’s not running propperly and has Failures while running.
When I use the AIO Interface, it says that the Apache contianer is running, but when I try to open the Nextcloud my Browser tells me “ERR_CONNECTION_TIMED_OUT”.

I already did increase the Buffer size, the message wont disappear. Don’t know if that is the cause of the Problem.

Hm… This reminds me of AIO Crashed and wont startup. same error when loading Linode backup or creating a new instance

Hi szaimen, the hint helped. I already tried to recreate the containers from the stack file, this doesn’t change anything.
After deleting everything, including the Volumes, the Port forwarding and everything, and redo it all it seems to work again :partying_face: Thanks a lot for your help!