Problem with Reverse Proxy (IIS Windows Server 2019 and preconfigured Nextcloud VM)

I’m testing the preview of the new Windows Server with the Nextcloud VM and I have used all my settings I have with my other Windows 2016 Server and an old Nextcloud VM (using Ubuntu 16.04), but the Reverse Proxy is not working properly (IIS 10 with URL Rewrite and ARR). I can reach the login page from outside (using the reverse proxy), can login, but then the problems start: the file app says “lost connection” and the notification are not clickable and so on. Settings seems to work fine and the log just says some problems with redis:

PHP Startup: Unable to load dynamic library '' (tried: /usr/lib/php/20170718/ (/usr/lib/php/20170718/ undefined symbol: igbinary_serialize), /usr/lib/php/20170718/ (/usr/lib/php/20170718/ cannot open shared object file: No such file or directory)) at Unknown#0

But I think that is not the problem here, because when I don’t use the reverse proxy, instead I use the local IP, everything works just fine. So this is a rewrite problem. I have configured the config.php with
‘overwrite.cli.url’ => ‘’,
‘overwritehost’ => ‘mydomain’,
‘overwriteprotocol’ => ‘https’,
‘htaccess.RewriteBase’ => ‘/’,

I have tested some configs with trusted proxy und http forward Headers but it didn’t work out. Maybe somebody has an idea where the problem could be :slight_smile:

EDIT: I moved a copy of my old Nextcloud VM to the new server, and with this VM the reverse proxy is working fine. So in conclusion, I would say that some settings of my new VM are preventing this from working.

so, I tried different scenarios, I have installed Nextcloud with Snap and normal with Ubuntu 18.04, but everytime this error (lost connection) occured. But with my old Ubuntu 16.04 VM it works…

Has something changed in the different Ubuntu versions which might be the reason for this strange behaviour?

EDIT: I have installed a new VM with Ubuntu 16.04 and Nextcloud with Snap, same error. So the different Ubuntu versions are not the problem here. I must have configured something in my old VM so that the rewrite is working there. But I don’t know which settings I have to change…

ok, I think i narrowed the problem down: the overwrite to my external domain is not working in the newly configured VMs. For example when I want to logout the address is internal.domain/logout?requesttoken=…

So Nextcloud isn’t using my given overwrite Domain. Anywhere else than the config file where I have to change something?

found the problem, I had a rule in IIS which handled URLs with remote in it, this caused that remote.php could not work properly. My old VM worked with /Nextcloud, so the rule wasn’t active für that, only when the URL had no subdirectory…
stupid misconfiguration, but well, it works now :slight_smile:

1 Like