Problem with nextcloud appstore installation / "escapeHTML"

i am having a problem with the static content (i guess)

when calling my domain, it just shows me the root directory (as files)

when running the upgrade script (i am on ubuntu)
i am getting following error message:

ERROR in /var/www/html/appstore/nextcloudappstore/core/static/assets/app/app/views/Migrate.ts
(4,9): error TS2305: Module ‘"/var/www/html/appstore/nextcloudappstore/core/static/assets/app/dom/Templating"’ has no exported member ‘escapeHtml’.
error Command failed with exit code 2.

does anybody have an idea?
Given i found not even a single person having the same problem,
i feel its some kind of newbe-style error and not a bug

thanks for helping

Yeah, it runs fine on our integration server and locally. I actually don’t know why you have the issue, the file does not exist anymore so I’d pull again :slight_smile:

thank you, i figured out most of the issues:

  1. compile error:
    besides numerous small mistakes, i seem to have mixed up versions, a clean fresh pull solved that.

  2. directory listing:
    I am redirecting from port 80 to 443. Unlike i was used to, the configuration

WSGIDaemonProcess apps python-home=/path/to/appstore/venv python-path=/path/to/appstore
WSGIProcessGroup apps
WSGIScriptAlias / /path/to/appstore/nextcloudappstore/
WSGIPassAuthorization On
Alias /static/ /var/www/
Alias /schema/apps/info.xsd /path/to/appstore/nextcloudappstore/core/api/v1/release/info.xsd

had to be in the config file, that describes the target domain instead of the starting domain.

I am still having some kind of permission problem, but i will try myself first and will ask later if i am in need.
this thread can be marked closed

thanks for helping

If you are having issues that you think should have been clear from the start, feel free to improve the documentation

yes i will do so after i finished everything around my project and i will collect a list,
while doing so.
Will need about two weeks,.

btw. all remaining issues solved by compiling mod_wsgi instead of installing it from repos.

breathtaking piece of software
:slight_smile: Matthias