Problem with Groupfolders, folders are EMPTY after 20.0.5 upgrade!


I have a problem this morning, since (i believe) the upgrade from 20.0.4 to 20.0.5 yesterday.

All my GroupFolders exists, but they are now EMPTY. Perhaps, files exists on the server (data folder has not decreased)

I’ve tried to occ files:scan --all but no result, they remain empty. :frowning:

How can i get back my files to display again at Groupfolders?


Hi @bloo, maybe by trying this :
sudo -u www-data php occ groupfolders:scan ‘id’

to find the id make this :
sudo -u www-data php occ groupfolders:list

read more : groupfolders/ at master · nextcloud/groupfolders · GitHub

Thanks, i’ve tried this for each folder, but…

php occ groupfolders:scan 1
| Folders | Files | Elapsed time |
| 1       | 0     | 00:00:00     |

Each time the output is the same (1 folder, 0 files, 00:00:00 time).


@bloo can you check if the files are present and if yes check the user permissions on them ( ls -l )

Files are on a S3 bucket. Bucket size remains the same than a few days ago so i believe files are still there. :frowning: