Problem with document editing via a public link in Collabora Online

Hi everyone,
For approximately 6 months, I have encountered a problem with Collabora Online (various versions, I update the collabora/code container weekly). The problem occurs when an anonymous user tries to edit documents in my Nextcloud instance via a public link (currently, my Nextcloud is in the version 28, but the error also persisted in the v. 27). When the anonymous user opens the document for editing, he/she should be asked for a nickname. However, the corresponding pop-up window does not show. Despite that, the user is capable of changing/commenting the document as “Anonymous user”. If the number of such anonymous users exceeds one, it becomes impossible to determine who made the given alteration in the text. Considering that most of the editors I work with do not have an account in my Nextcloud service, the simultaneous editing of documents is practically impossible. Notably, the mentioned pop-up window does not appear irrespective of whether the user uses the Firefox or Chrome browser. The problem remains even after stopping the collabora/code docker container and enabling the Collabora Online - Built-in CODE Server.

My current system info:

Nextcloud version:
Collabora online version:
Apache server version: Apache/2.4.52 (Ubuntu)
Docker version: 24.0.5, build 24.0.5-0ubuntu1~22.04.1
PHP version: 8.1.2-1ubuntu2.14
MySQL version: 15.1 Distrib 10.6.16-MariaDB, for debian-linux-gnu (x86_64).

Nextcloud app list:

  • activity: 2.20.0
  • admin_audit: 1.18.0
  • analytics: 4.12.0
  • audioplayer: 3.4.1
  • calendar: 4.6.6
  • carnet: 0.25.4
  • circles: 28.0.0-dev
  • cloud_federation_api: 1.11.0
  • comments: 1.18.0
  • contacts: 5.5.3
  • contactsinteraction: 1.9.0
  • dashboard: 7.8.0
  • dav: 1.29.1
  • deck: 1.12.2
  • event_update_notification: 2.3.0
  • federatedfilesharing: 1.18.0
  • federation: 1.18.0
  • files: 2.0.0
  • files_pdfviewer: 2.9.0
  • files_reminders: 1.1.0
  • files_sharing: 1.20.0
  • files_trashbin: 1.18.0
  • files_versions: 1.21.0
  • firstrunwizard: 2.17.0
  • groupfolders: 16.0.4
  • logreader: 2.13.0
  • lookup_server_connector: 1.16.0
  • maps: 1.3.1
  • nextcloud_announcements: 1.17.0
  • notifications: 2.16.0
  • oauth2: 1.16.3
  • password_policy: 1.18.0
  • passwords: 2024.3.10
  • phonetrack: 0.7.7
  • photos: 2.4.0
  • privacy: 1.12.0
  • provisioning_api: 1.18.0
  • recommendations: 2.0.0
  • related_resources: 1.3.0
  • richdocuments: 8.3.2
  • serverinfo: 1.18.0
  • settings: 1.10.1
  • sharebymail: 1.18.0
  • spreed: 18.0.5
  • support: 1.11.0
  • survey_client: 1.16.0
  • suspicious_login: 6.0.0
  • systemtags: 1.18.0
  • tasks: 0.15.0
  • text: 3.9.1
  • theming: 2.3.0
  • twofactor_backupcodes: 1.17.0
  • twofactor_totp: 10.0.0-beta.2
  • unsplash: 2.2.1
  • updatenotification: 1.18.0
  • user_status: 1.8.1
  • viewer: 2.2.0
  • weather_status: 1.8.0
  • workflowengine: 2.10.0
  • bruteforcesettings: 2.8.0 (installed 2.0.1)
  • encryption: 2.16.0
  • files_external: 1.20.0
  • onlyoffice: 9.0.0 (installed 9.0.0)
  • user_ldap: 1.19.0

Thanks in advance for Your help and support.
Best regards,

Sometimes there is an interaction with manual installed apps or disabled apps. Maybe you can uninstall them. Also you can use browser DEV tools (F12) and there options e.g. network analysis. Maybe there is a load problem (HTTP != 200) or JavaScript problem. Do you use adblocker? Please deactivate them. Also use another PC and browser. Post details, tests, logs, …

1 Like

I am afraid that this problem is more general in it’s nature and not confined to my Nextcloud installation only. There are several premises supporting this hypothesis. Firstly, I have already tried different PCs, web browsers (Firebox and Chrome) and even various operating systems (Manjaro and Ubuntu Linux and also Windows). Removal of disabled Nextcloud apps and Adblocker inactivation did not solve the problem, too. The same error occurred when I used a completely new Firefox profile with no add-ons installed. Moreover, the nickname pop-up window is also missing when I tried to edit a document via a public link on an official Nextcloud demo server. Interestingly, while performing this experiment, I figured out that the lack of pop-up window with a nickname request occurs only if the link points to the directory where the document of interest is stored. When one creates a public link pointing out to this document directly, the aforementioned pop-up window appears. In my personal Nextcloud instance, I encountered the same regularity. Thus, this function works for links to the documents but not if the link to the entire folder is shared with unregistered Nextcloud users. Could You, please, modify this function so that all types of public links give anonymous users the possibility to provide their nicknames? Such amendment would be very helpful.
With best regards,