Problem with Collabora Online nginx setup

Hey there,
i just tried to set up Collabora Online following this guide:

However, if i visit the subdomain, which i set up for Collabora (, i get the nginx welcome page.
I started the container with:
docker run -t -d -p 9980:9980 -e "" --cap-add MKNOD collabora/code

Collabora online server setting in owncloud admin is set to:

Any help is appreciated.

cc @icewind Any thoughts on this?

This should be the domain Nextcloud is running on, not the domain for the docker server.

It’s normal for the root of the domain ( to show the nginx welcome screen since all collabora related things are in subdirecties. Collabora online should be accessed trough the nextcloud app.

Thanks for the quick replies.
Ok, I set it to -e "".
Now i get this on the application page:

Collabora Online unbekannter Fehler: cURL error 52: Empty reply from server

Hi, i’m having the same issues. It doesn’t completely seem to work, the docker image runs and is accessible.
I can open the Documents app, and I see my documents, and have the buttons to create a new one.
However, when I open a document or try to create a new document, I get: We are sorry, this is an unexpected connection error. Please try again.

Debug log shows:

This seems to be a different issue. I don’t even see my documents. I now get:

Problem loading page, reloading in 5 seconds

@archit3cct at what point does the error show up?

The loading indicator has 2 “stages”, a thin one with no text and after that a thicker one with “connecting” under it.
If the error happens at the second stage that means it connected to the docker server correctly and it’s likely an issue with the collabora online server.

If the error happens during the first stage you can try applying this patch to the nextcloud app.

@lukas does discover give a sensible output (an xml file with a bunch of links)

Hi icewind, it happens on the 2nd stage, with the thick loading animation.

Yes, there is an output.

@archit3cct have a look at the docker logs, look for something like

Loading new document from URI: [file:///user/docs/35/New%20Document.odt] for session [0002]

And see if there are any errors after that

@lukas do I understand correctly that you don’t even get to the list of documents (something like this)?

Are you sure you configured the “Collabora Online server” correctly? (no leading slash, https)

@icewind I checked the logs…and it seems its blocking the server’s external IP:
WOPI host is not on the same host as the WOPI client: “149.210..”. Connection is not allowed.^[[0m
^[[1m^[[31mwsd-00020-22 00:04:45.604027 [ client_ws_0002 ] No acceptable WOPI hosts found matching the target host [cloud..] in config.^[[0m

I have no idea how to change this tho.

Make sure you provided the correct domain to the docker (-e domain=....)? it uses that to determine which servers are allowed, setting the domain name of the nextcloud server should work. shows:

Yes, it’s empty:

@lukas anything in the browser’s console log?


Hmm, that doesn’t seem related to the collabora docker, anything in the owncloud log (try setting the minimum log level to debug to)

Thanks for your patience :see_no_evil:
There are some entries which say:
Error PHP Undefined index: dir at /usr/share/nextcloud/apps/richdocuments/controller/documentcontroller.php#289
But they could be caused by the wrong domain i set previously.
There are also some entries with:
Debug no app in context getDiscovery(): Getting discovery.xml from the cache.

Is expected

Looks related to trying to create a new document