Problem uploading files larger than 8-10MB

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 15.0.4*
Operating system and version (eg, Ubuntu 17.04): * CENTOS 7.6 virtuozzo [vps] * [ v78.0.11 ]
Apache or nginx version (eg, Apache 2.4.25): EasyApache 4.0, Apache/2.4.38, Nginx Version: 1.9.14
PHP version (eg, 7.1): 7.2.15

The issue you are facing:
When I try to upload a file larger than 8-10MB browser displays “Processing files …” and remains on that forever.
When I try the desktop app to sync with server I get error: Server replied “405 Method Not Allowed” to “MOVE” (… filename
If I use WebDav on my mac using finder I end up with files that are 0bytes.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Upload any file larger than 10MB (I am trying a 20MB file)
  2. Same using desktop app sync
  3. And ditto Webdav

The output of your Nextcloud log in Admin > Logging:

There is nothing in the logs except my earlier failed login attempts while testing

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'ocsadxkubslk',
  'passwordsalt' => '2pu08nmeeodjm8dtxkjdq9awfcurh5',
  'secret' => 'ebn086v5gypafsmgslowphs8lcri9cxazl0uvxen8gk07cfo',
  'trusted_domains' => 
  array (
    0 => '',
  'datadirectory' => '/home/kanboard/biclouddata',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'kanboard_next750',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'myusername',
  'dbpassword' => 'apassword',
  'installed' => true,

The output of your Apache/nginx/system log in /var/log/____:

I am not seeing anything in the logs.

Edit your php.ini file
(usually stored in /etc/php.ini or /etc/php.d/cgi/php.ini or /usr/local/etc/php.ini):

Add or change the following lines:

memory_limit = 320M
upload_max_filesize = 100M
post_max_size = 200M

I didn’t find any php.ini at any of those locations, only in the public_html folder
That didn’t change anything unfortunately.

I installed a new installation using server-master from github
Now I get an error when i try to upload the same file approx 19MB
“Error when assembling chunks, status code 405”

NOTE: I am running multiple cpanels on my server, not that that should make a difference. Right?

PS. I just installed FlowUpload app and that works fine.

Hi guys,

Is there any chance this problem will get fixed? I get the same error "Error when assembling chunks, status code 405” when I upload a file that is bigger than 9.9MByte.

The reason I think this should be fixed:

  • A folder shared as filedrop works perfectly with every file size
  • FlowUpload works as well (thanks @Nagui_Bihelek )

These are just workarounds as I have to move the file to the destination folder afterwards as the filedrop and FlowUpload put the files in one specific folder.

As I’m running NextCloud on a hoster I cannot change the php.ini. My values (full list here:
memory_limit = 256M
upload_max_filesize = 32M
post_max_size = 32M

I would understand when you say “Tough luck if I can’t change php.ini”… but: FileDrop works perfectly! So why is that?


I found my issue:

in my .htaccess file I had the line
RedirectMatch 404 /(?!.well-known)(.)\w+

which was added by the Statamic framework.
Once I deleted this line everything worked again.

Hope this helps someone.


1 Like