Problem to set the max upload limit size


I have just installed the version 9.0.52

My problem is that I can’t change the max upload file size.
The steps I follow as usal don’t work.

By default the max size is set to 2 MB
I can change the value using the admin menu… It seems to works

  • the value is updated in the dedicated field
  • If I edit the file .htaccess the field is updated with the right parameter.

Then I try to upload a document… and an error message appear and inform me that it is not possible to upload a document with a size upper than 2 MB…
If i restart the apache server or the server… the problem still exists.
The default value is set to 2 MB and I can’t change it…

I used for many years owncloud, I have done a migration from owncloud 9 to nextcloud 9. Everything was fine.
Today I have done an update to nextcloud 9.0.52 and detect this new problem.

For information: I can’t upload this “big” document with the web interface… but I can upload it by using the windows sync app …

Any idea ?
Is it a bug ?

I have to change directly the values in the file /etc/phpX/apache2/php.ini for upload & post max size if I want to do it in Nextcloud. The changes I did using the webinterface doesn’t works.

  • no warning or error in logs

Thanks for your help

1 Like

…and always remember to restart your server (ie Nginx/Apache etc) and PHP to get the new settings to take effect…

Same issue here on version 9.0.52. .htaccess is getting set correctly however phpinfo() still shows the 2M max is not being updated. I would think this is not a nextCloud issue but a php / apache config issue.

I updated the upload_max_filesize in /etc/php//apache2/php.ini to set this correctly.


I have a similar problem.
Standard was 513MB, I tried to change it to 2 GB but it still shows 513MB. Then I tried 1 GB and this worked.
I set it to 512MB and it still showed 1GB but in the .user.ini it showed 512MB. I set it to 2GB and in the admin page it showed 512MB and the .user.ini was also 512MB.

So 2GB doesn’t work in any way and everything else seems to have a display issue.

EDIT: I think I found the reason. If you set all ownership an privileges according to the Owncloud/Nextcloud installation guide you end up with a .htaccess -rw-r–r-- 1 root http. The webserver now can’t write to the htaccess. In my case it still writes to .user.ini (as I have changed it to http:http) if you also change the .htaccess to http:http (or whatever your web user is called) it works.

@Thor For the permissions you can use this usefull script …

1 Like

That’s the script I actually used and where you end up with an restricted .htaccess and .user.ini

Okay you are right with the permissions :slight_smile: Just checked it …

I’m writing to you here because my problem is similar. I have pi 3 B+. I install nextcloud with dietpi. I have webserver lighttpd. My problem is that I upload videos larger than 4GB and the file goes up to 4GB. The result is that the video is not playing properly. I have version 17 of nextcloud. Do you have any suggestions? Thank you