Problem talk nextcloud

I’m having some performance issues with the Talk app in my Nextcloud instance. I’m new to Nextcloud, I just recently got it running for my small team of 4. I’ve been very happy with it except for these performance issues with Talk. I use several other apps (see below) and they all seem snappy and performant as long as the Talk app is disabled. I’m looking for help digging into what might be causing the performance issues. I’ve tried the obvious things like running top on the host and tailing logs, but I haven’t yet found a likely root cause.

The repro is easy: enable Talk, click back and forth between a couple conversations. Try and click away to another app (e.g. Files) and it could take 20-40 seconds. Eventually page views may speed up. I can also restart the server to get Nextcloud back to normal speed. During the repro I see no noticeable server load, no obvious issues in the logs. So far my workaround is to disable the Talk app.
server : nextcloud 29.0.1
php8.3
apache2
db : maradb

type or paste code here
```<?php
$CONFIG = array (
    'trusted_domains' =>
  array (
    2 => '192.168.110.2',
    4 => '192.168.7.110', 
  ),
  'datadirectory' => '/var/www/data',
  'dbtype' => 'mysql',
  'version' => '29.0.1.1',
  'overwrite.cli.url' => 'https://192.168.110.2',
  'dbname' => '*******',
  'dbhost' => 'localhost:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '*******',
  'dbpassword' => '******',
  'installed' => true,
  'enable_preview' => false,
  'memcache.local' => '\OC\Memcache\APCu',
  'memcache.locking' => '\OC\Memcache\Redis',
  'memcache.distributed' => '\OC\Memcache\Redis',
  'filelocking.enabled' => true,
  'redis' =>
  array (
    'host' => 'localhost',
    'port' => '6379',
    'timeout' => 0,
    'dbindex' => 0,
  ),
  'trusted_proxies' =>
  array (
    0 => '192.168.110.0/30',
    1 => '192.168.7.110',
  ),
  'default_phone_region' => 'IR',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => *****',
  'mail_domain' => 'gmail.com',
  'mail_smtphost' => 'smtp.gmail.com',
  'mail_smtpport' => '465',
  'mail_smtpauth' => 1,
  'mail_smtpname' => '********',
  'mail_smtppassword' => '*******',
  'mail_smtpsecure' => 'ssl',
  'maintenance' => false,
  'maintenance_window_start' => 1,
  'allow_local_remote_servers' => true,
  'session_lifefime' => 21600,
  'session_keepalive' => true,
  'remember_login_cookie_lifetime' => 1296000,
  'davstorage.request_timeout' => 30,
  'session_relaxed_expiry' => false,
  'theme' => '',
  'updater.release.channel' => 'stable',
  'logfile' => '/var/log/nextcloud.log',
  'loglevel' => 2,
  'debug' => false,
  'check_for_working_htaccess' => true,
  'files_no_background_scan' => false,
  'defaultapp' => 'dashboard,files,spreed,announcementcenter',

Hey, check that you’re using the correct mpm module: Server system requirements - Nextcloud Talk API documentation. Also, since talk is using long polling, make sure you have enough workers to process the requests.

Can you help me more? Which part should I go to?