Problem syncing files with NextCloud Android-app to server

Nextcloud version: 18.06
Operating system and version: LineageOS 17.1
Apache or nginx version: Apache (unsure which version)
PHP version (eg, 7.1): 7.3

The issue you are facing:
I can’t sync files larger then ~250KB to my Nextcloud Server using the Android-app. The app returns the error “Method not allowed”, in the Apache error log it reads:

AH01623: client method denied by server configuration: 'MOVE' to /path to nextcloud/public_html

I also have 2 desktop clients (Fedora & Manjaro) which are working fine.

Is this the first time you’ve seen this error? : N, I have this error since NC13 but did never resolve it. Hope someone here can help me.

I am using a shared hosting provider to host Nextcloud, so I do not have access to all settings.

Steps to replicate it:

  1. Take photo
  2. Go to ‘Files’
  3. Select photo
  4. Click ‘Share’ button
  5. Select NextCloud-app option

It then will start the upload and reports ‘Method not allowed’ upon completion.

The output of your Nextcloud log in Admin > Logging:

Nothing here related to the failed upload

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'xxx',
  'passwordsalt' => 'xxx',
  'secret' => 'xxx',
  'trusted_domains' => 
  array (
    0 => 'mydomain.xx',
  'datadirectory' => '/path to nextcloud/public_html/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://mydomain.xx',
  'dbname' => 'dbname here',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'dbuser here',
  'dbpassword' => 'password',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'xxx',
  'mail_domain' => 'mydomain.xx',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'mail.server.xx',
  'mail_smtpport' => '465',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpname' => 'xxx',
  'mail_smtppassword' => 'password',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'updater.secret' => 'secret',

The output of your Apache/nginx/system log in /var/log/____:

AH01623: client method denied by server configuration: 'MOVE' to /path to nextcloud/public_html/remote.php

Have you installed and configured the web server and Nextcloud on your own or are you using a pre-configured Nextcloud environment of your hoster?

Thanks for your reply, I did not setup the webserver but did install NextCloud myself. I only have some limited controls over the used php settings and modules.

I have created a ticket with support, see what they have to say.

If I understand it correctly, another possible fix would be changing the MOVE method to a POST - DELETE in the app itself, right?

I’ve not read all the provided information, but trying to patch the source code is usually counter productive because you have to apply the patch with every new update. Better is to fix the problem by getting the web server correctly configured.

Turns out my hostingprovider does not allow cloudstorage programs to be installed on their platform, I have to remove it within 24hrs :frowning: