Problem running OnlyOffice


#1

Hello,

i tried to install OnlyOffice instead of Collabora because Collabora isnt running for me.
So i tried:
sudo docker run -i -t -d -p 443:443
-v /app/onlyoffice/DocumentServer/data:/var/www/onlyoffice/Data onlyoffice/documentserver

But i am recieving an error:
1ba775a25ef7280952cd43ec67ca3d122bc356b29631b91a4958632bdb4de402
docker: Error response from daemon: driver failed programming external connectivity on endpoint cranky_roentgen (72bf929d05694c39353691ada97beb20fe97f7fcf517ce9fceb0d3e8f2b6ef4a): Error starting userland proxy: listen tcp 0.0.0.0:443: listen: address already in use.

Does somebody have a solution for this issue?
Thanks alot


#2

Sounds like there is already a web server running on port 443. I assume you’re trying to install OnlyOffice on the same machine Nextcloud runs on? Then there will be Apache/ Nginx which runs on 443 (HTTPS). You would need to change the port for the docker installation - or for the NC installation.

Maybe:

sudo docker run -i -t -d -p 8443:8443 -v /app/onlyoffice/DocumentServer/data:/var/www/onlyoffice/Data onlyoffice/documentserver

#3

i thought onlyoffice doenst support custom ports? No i tried to install it on an VirtualMachine running on the Nextcloud host

I found this installation guide: https://serenity-networks.com/how-to-install-onlyoffice-document-server-for-nextcloud-fast-easy/

Does anybody tried this with apache2?
Is there somebody who convertet the .conf file to apache2?
My knowledge is bit to small to do this :slight_smile:

Thank you


#4

Oh yes, you are right. Onlyoffice should run on 443 then and you need to change the ports for Nextcloud.
As far as I know Onlyoffice comes with nginx and it is pretty easy to setup a proxy with nginx.
So you can easily change the ports for Nextcloud to 8180 (instead of 80) and 8443 (instead of 443) then and install Onlyoffice afterwards.

I can suggest this tutorial to setup Onlyoffice on Nextcloud server with nginx configured as proxy.
By the way: I heard that apache2 isn’t supported by Onlyoffice and that it is a pain in the ass to configure apache to run with Onlyoffice. Probably something you should avoid. I simply used nginx as well.


#5

Thank You Schmu!

Did you have any Problems installing OnlyOffice?


#6

A lot! :smiley:

Actually I am everything but happy with OnlyOffice. I got it running after 2 weeks finally and now that I can finally see what it is actually capable of, I am very disappointed.
There is no obvious way to change the GUI language to the preferred one and while some of my users are not very comfortable with using an english Office GUI I can’t use it like that. When you have a look at the forum of Onlyoffice (http://dev.onlyoffice.org) you may be shocked as much as I am. This looks like pretty dead community there and the forum is HTTP only (no even for login form HTTPS) and when you post a question you have to wait days before the moderation had reviewed your question and passes it on to the public. And then the moderator is the only one answering (my impression).

The feature list of Onlyoffice is pretty small. There is no “conditional formatting” (if that’s the correct name of that function) and no pivot tables.

What I also expected was the possibility to share a Excel file to the public and edit the file collaboratively with users that don’t have an account on my server, but that’s not possible. Other users can only download the file then.

I’m already thinking about uninstalling Onlyoffice again and giving Collabora online a shot.

Oh, some hints: when you want to install Onlyoffice on the same server as Nextcloud, make sure redis is not running in socket mode for Nextcloud. You need to have redis running in TCP mode and listening on port 6379.
Furthermore don’t disable IPv6 via sysctl.conf - I did and then nodejs will not open port 8000.


#7

Thank you for the hints.
I already tried collabora but it doenst seem to be better.
Not very stable and some unkown errors.

I recieved an “access forbidden” error everytime.

No fix is available for this and all solutions are just trying results of the community. Think you wont be more happy with collabora :slight_smile:


#8

Oh, great! :frowning:
So we use our super private Nextcloud server and Google Docs in addition :stuck_out_tongue:

I think it’s time that the good guys from Nextcloud build a “Nextcloud Office” :wink:


#9

Sounds super private and secure !!! :smile: :smile:


#10

Hi there,
You are able to expose the 443 of onlyOffice to another TCP port using docker itself. (exposed port don’t have have to be equal to container’s port)
example:

sudo docker run -i -t -d -p 8443:443 -v /app/onlyoffice/DocumentServer/data:/var/www/onlyoffice/Data onlyoffice/documentserver

this command creates a container bound to the docker host’s TCP 8443 listening on all interface but internally redirected to the container’s tcp 443
or, from an “outsider” perspective, onlyOffice is available at port 8443 using https.

this whould allow to run the container on the same host than a webserver using https.
However it may imply the uses of a reverse proxy to keep clients apps compatible or simpler to configure (to avoid specifying the customized port).
Regards, Aal.


#11

Thank you aalaesar.

I installed OnlyOffice now, startet the container and edited the ip in nextcloud settings.
I created a new pptx for testing but i am recieveing an Error: “OnlyOffice not configured. contact admin”

Does anybody already have a solution for this?

Thanks


#12

@ftaut You may need SSL on the OnlyOffice instance, without SSL it will not work.

https://helpcenter.onlyoffice.com/server/linux/document/switch-to-https.aspx


#13

Already solved the problem by entering the url of the documentserver in my browser.
After this i was able to open documents