Problem downloading files from Nextcloud with IDM (Internet Download Manager)

Hi I’m using NextCloud (NextCloudPi 24.0.5) installed on Rasperry Pi4 with Docker and Portainer.
When I try to download a file with IDM (Internet Download Manager) as soon as the download starts, the NextCloud GUI remains blocked for all users for a long time. If I download the files without IDM everything works perfectly. Is it possible that the block is caused by the overload of the multiple connections that IDM creates to download the file? … is there a way to set the NextCloud server to prevent or limit multiple connections on the same file?
thank you

Can you post details for the software and the configuration? Do you use e.g. WebDAV url for access? Maybe you can better use the Nextcloud client.

I installed the ownyourbits/nextcloudpi image on Openmediavault via Docker / Portainer on Rasperry Pi4 8GB Ram.

You could try to block / disable the Content Range Header in your web server config or Reverse Proxy.

Here are two examples I found with a quick google search:



This would probably be the better way to go. Most download managers do have an exceptions / ignore list, Just add the URL of your Nextcloud server to that list → problem solved.

The problem is that there are some users who use IDM and not knowing these things when they download files with IDM they block the whole system. I need to set something up on the server side.

Then you could try the range headers thing. But be aware that browsers and the Nextcloud client are also multiplexing downloads, but they are probably doing it in a less aggressive way than IDM. So I’m not sure, if there is an easy way to achieve what you want, without causing unwanted side effects. Maybe it’s somehow possible to limit the number of connections or setting certain time limits…

Since I’m not really a geek of the linux world could you please post the commands to insert in which paths and files?
Tanks :wink:

Sorry, I can’t give you detailed instructions, because I did not test this myself, and as I said, there is a high possibility that this solution is not the final answer to your issue, or even causes unwanted side-effects. It was just an idea, that you maybe could have tried out…

And no offense, but if you don’t know how to edit the web server config of your server, then maybe you should start learning it and then you could go on to this: Server tuning — Nextcloud latest Administration Manual latest documentation. And if there are still issues after going through all that, and your friends really can’t be talked out of using IDM, then you could maybe try something like the thing I brought up…

ok. however the question that arises is … how is it possible that NextCloud crashes when users use IDM? … possible that there was no way to limit this overload within nextcloud? … it is strange that this problem only affects my installation of Nextcloud on Rasberry …

First of all, I’m not an expert when it comes to this. Also, last time I used Download Managers was probably in the 90s or early 00s, when I still had Dial-up Internet :wink: But my theory is, that IDM is just too aggresive and creates too many connections in a very short time and therefore virtually DDOSes your server.

How many connections your server can handle, depends of course on HW resources, because even fully optimized config, can only handle so much, if it is running for example on a Raspberry Pi. But there are maybe still things you can do. With Apache for example it makes a huge difference whether you use MPM prefork or MPM event. How To Configure Apache HTTP with MPM Event and PHP-FPM on Ubuntu 18.04 | DigitalOcean

So I can’t offer you a one-size-fits-all solution for your issue. The basic requirement, that someone could even start with offer more detailed suggestions, would be more details about your instance (HW and software configuartion), but even then it’s not something you can solve by copying and pasting two commands.

ok thank you very much for your support … for the moment I don’t have the advanced knowledge to handle Linux configurations so in depth … I hope that the problem will be solved by itself with future updates of the NextCloud system and its Docker …:wink: