Problem displaying text and md files

I’m running Nextcloud 28.0.5 (on Ubuntu), and Nextcloud Hydrogen for iOS 5.3.0.21.

When I attempt to display a text files (both *.txt and *.md) in the iOS app, all that I get is a blank white screen with a solid blue bar at the top of the screen.

When I display a text file using a browser, the *.txt files will display just fine, but not the *.md files. And once I tried displaying one *.md, attempting to display a 2nd *.md file hangs the browser session. I’ve tried it using both Firefox and Chrome browsers.

I’m guessing the problem is probably with more with Nextcloud than the iOS app.

Does anyone have any suggestions?

Please post the output of occ app:list.

Can you elaborate on what you mean by “hangs”?

Here’s the output from occ app:list:

$ sudo -u www-data /var/www/nextcloud/occ app:list
Enabled:

  • activity: 2.20.0
  • bruteforcesettings: 2.8.0
  • circles: 28.0.0
  • cloud_federation_api: 1.11.0
  • comments: 1.18.0
  • contactsinteraction: 1.9.0
  • dashboard: 7.8.0
  • dav: 1.29.1
  • federatedfilesharing: 1.18.0
  • federation: 1.18.0
  • files: 2.0.0
  • files_pdfviewer: 2.9.0
  • files_reminders: 1.1.0
  • files_sharing: 1.20.0
  • files_trashbin: 1.18.0
  • files_versions: 1.21.0
  • firstrunwizard: 2.17.0
  • groupfolders: 16.0.6
  • logreader: 2.13.0
  • lookup_server_connector: 1.16.0
  • nextcloud_announcements: 1.17.0
  • notifications: 2.16.0
  • oauth2: 1.16.3
  • password_policy: 1.18.0
  • photos: 2.4.0
  • privacy: 1.12.0
  • provisioning_api: 1.18.0
  • recommendations: 2.0.0
  • related_resources: 1.3.0
  • serverinfo: 1.18.0
  • settings: 1.10.1
  • sharebymail: 1.18.0
  • support: 1.11.1
  • survey_client: 1.16.0
  • systemtags: 1.18.0
  • text: 3.9.1
  • theming: 2.3.0
  • twofactor_backupcodes: 1.17.0
  • updatenotification: 1.18.0
  • user_status: 1.8.1
  • viewer: 2.2.0
  • weather_status: 1.8.0
  • workflowengine: 2.10.0
    Disabled:
  • admin_audit: 1.18.0
  • encryption: 2.16.0
  • files_external: 1.20.0
  • suspicious_login: 6.0.0
  • twofactor_totp: 10.0.0-beta.2
  • user_ldap: 1.19.0

By “hangs”, I mean when you click on the second .md file, I get the “spinning wait circle” and it just keeps spinning and spinning and spinning and nothing happens. The web pages showing the listing of the files is still displayed. And if I try clicking on anything else on the page, nothing happens.

It happens in both Firefox (versions 1115.9.1esr and 1115.11.0esr) and Chrome 109.0.5414.168.

As I was double checking for this email, attempting to display the 2nd .md file can cause the browser to display a “Bad Gateway” error and I needed to restart the web service by doing:

sudo systemctl restart nginx
sudo systemctl restart php8.2-fpm

Further testing has also shown that some .md files actually do show. On the ones that seems to be causing problems do contain URLs. That may be be causing an issue. The files are okay on the disk as I can open them in nano.

I had some similar issue and I solved it by installing Markdown Editor. Keep in mind, it is not supported for your Nextcloud version, so test at your own risk. I tested it on both Nextcloud v28 and v29, and it did not break my installation, but be careful.