Problem configuring a proxy on my web-based NC 27.1.3

I’ve been using Nextcloud for a few years, but everytime I try to re-install it on my Web hosting account, I run into troubles. :sweat_smile:

This time, I really have no idea what is going on. :question: :interrobang:

I have tried to find answers on this and other fora, but everyone seems to have this kind of troubles as they have self-hosted Nextcloud or they try to access them through a docker (I have no idea what it is yet), etc. To be honest, I don’t understand their questions, nor the answers, so I hope I’m not being redundant here, but I’m really completely ignorant on this issue.

Basically, I have installed Nextcloud Hub (version 27.1.3) .on my account with a web hosting company in Switzerland (infomaniak) and things went well until I tried to access Nextcloud on the web after the installation.

There, I had a first alert. It told me that the server was receiving too many requests and that logins would be significantly slowed down. I tried connecting my computer to my mobile network and the problem disappeared.

When I wasd finally logged in, I went to the “Overview” page and found this warning in red fonts:

Your remote address was identified as “83.78.114.6” and is bruteforce throttled at the moment slowing down the performance of various requests. If the remote address is not your address this can be an indication that a proxy is not configured correctly. Further information can be found in the [documentation].

The link leads to the Nexcloud documentation page about Reverse proxy. And I must say I’m totally at a loss here, as I don’t understand anything in the explanations. I have tried to figure out the content, by looking up the various terms, but it’s like tumbling down the rabbit whole. At one point, I don’t even know anymore what I’m looking for and have dozens of opened tabs on my browser.

So I was wondering if someone could guide me a bit through this. I don’t dare adding extension to my Nextcloud and setting up any synchronizations yet, as I’m afraid that it might simply not work. And I don’t want to add stuff that might make things more complicated.

Some informations about what I’m using:
My computer is running Ubuntu 23.10 and I have installed Nextcloud Hub 27.1.3 on my account at the web hosting company Infomaniak. As they are not contributors to Nextcloud, they consider it a third-party service and don’t provide technical support for it.

If you need more information in order to help me, please, let me know. I’ll try my best. I feel stressed, because all my agendas, contacts, notes, etc.,are synchronized to my other devices through Nextcloud, so now I’ve got all my data only on my computer, but I need these on my phones and tablets, for both personal and professional use. :pleading_face:

Thank you all in advance for your kind help!

This is what you can do.

Look if that is your wan ip with http://checkip.dyndns.org

According to whois, it is a bluewin address, so that would be possible.
Maybe you just entered too much wrong passwords.

Workaround/Solution:

Go to your appstore and enable the (shipped) App Brute-force settings
Then you can add your IP to the whitelist in the security tab of your Admin-Section.

Much luck,
ernolf

1 Like

I tried, but now, it breaks the connexion and tells me the following:

Internal Server Error
The server was unable to complete your request.
If this happens again, please send the technical details below to the server administrator. More details can be found in the server log.

Technical details

  • Remote Address: 2a02:1210:7a10:3300:fcaf:2d2:456c:db7d
  • Request ID: ZVId4Z7BEgv3LXLAQo5U5AAAAQ8

I have no idea how to get to the technical log if I can’t even access my Nextcloud or the connexion is interrupted constantly, because of my IP.

[EDIT]
Ok, I have finally been able to reconnect, and I get a long list of logging error, with the my IP number (the one mentioned above). I have installed the extension in question, but the modification of the trusted proxy list doesn’t work. I have input my proxy IPV6 and added a number between 0 and 128, but nothing happens, when I ask to add.

I have also made sure that all clients are disconnected from my nextcloud.

Here the manual, explaining what is happening:
https://docs.nextcloud.com/server/stable/admin_manual/configuration_server/bruteforce_configuration.html

When you install the App Brute-force settings, you should enter the IP in the whyitelist, not in a “trusted proxy list”.
When the Brute-force settings app is enabled, you’ll find that whitelist under:

https://<example.com>/index.php/settings/admin/security

and this is how it looks like:

So returning to your case, when you want to ad one single IP to the whitelist, you should enter the IP (83.78.114.6) in the field before the “/” and 32 in the field behind the “/” and then klick “+Add”
Much luck,
ernolf