Problem after migration from owncloud 9

Hi all.
I migrate my onwcloud 9 to nextcloud 9 (or 10 can’t remember now) then update to nextcloud 11 then 12 few days ago.

And suddenly, today, My nextcloud is messed up, There is no css I can’t view my files due to that error in console I guess : previewplugin.js:122 Uncaught ReferenceError: OCA is not defined
previewplugin.js:122 Uncaught ReferenceError: OC is not defined

I have these errors in lot of js files.

I checked my files, I stilll have my data folders ans all the data inside.
BUt the error comes suddenly, without done anything. that’s pretty weird.

Thanks in advance.

edit : I tried to disconnect then reconnect, I can’t connect as the buton is disabled.
And I have these errors in the console on login page:

edit2 : I search the source of OC and OCA variable.
It’s in js/js file
But this file is not included in the pages of my nextcloud (The file exists in my nextcloud install folder, it’s just not included in the pages).

Ok I found that the js.js file is not included n the pages, but can’t know why.

Anyone can help me to know why ? ^^"

Seems it comes from the database.

before the migration i made a mysqldump of owncloud db and create a nextcloud db with the dump
but when I connect nextcloud with the new nextcloud db it doesn’t work…
I checked the GRANT privilege and the user used for nextcloud has all the privileges on owncloud and nextcloud db so I don’t understand why it doesn’t work…

I wanted a clean installation but it messed up the whole thing ^^"

Did you try clearing the cache and using another browser/PC? Maybe there was just a temporary hiccup and your system cached the broken script.

yep I tested another pc and browser but the problem were still the same.

Like I said, It seems to be db related.

I re-use my “owncloud” db (as i had owncloud before) but would like to use my “nextcloud” db to have a clean installation.
But it seems just a mysqldump doesn’t work.

Is there another way to rename a db or copy all the data/param of a db ?

I am getting the same thing. Did you find a solution? I upgraded from 12 to 12.03.

Frankly - having bit of a guts full of nextcloud updates.

First error is

GET https://blah.blah/index.php/js/core/merged-template-prepend.js?v=18147a85969ace53926171d80027efd7-0 net::ERR_CONTENT_LENGTH_MISMATCH

then a load of
Uncaught ReferenceError: OC is not defined
Uncaught ReferenceError: OCA is not defined