Problem accessing the file extension with docx, xlsx and pptp from nextcloud

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:

Some or all of the below information will be requested if it isn't supplied; for fastest response please provide as much as you can :heart:

Operating system: Linux 3.10.0-1062.1.1.el7.x86_64 #1 SMP Fri Sep 13 22:55:44 UTC 2019 x86_64

Webserver: Apache/2.4.6 (CentOS) PHP/7.2.10 (apache2handler)

Database: mysql 10.4.8

PHP version: 7.2.10

Modules loaded: Core, date, libxml, openssl, pcre, zlib, filter, hash, Reflection, SPL, session, standard, apache2handler, bz2, calendar, ctype, curl, dom, mbstring, fileinfo, ftp, gd, gettext, iconv, intl, json, ldap, exif, mysqlnd, PDO, Phar, posix, shmop, SimpleXML, sockets, sqlite3, sysvmsg, sysvsem, sysvshm, tokenizer, xml, xmlwriter, xsl, zip, mysqli, pdo_mysql, pdo_sqlite, wddx, xmlreader, apcu, igbinary, imagick, smbclient, redis, libsmbclient, Zend OPcache

The issue you are facing:
File extension with docx, xlsx and pptp are no accessible.

Is this the first time you’ve seen this error? (Y/N): Y

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

    "instanceid": "***REMOVED SENSITIVE VALUE***",
    "passwordsalt": "***REMOVED SENSITIVE VALUE***",
    "secret": "***REMOVED SENSITIVE VALUE***",
    "trusted_domains": [
    "trusted_proxies": "***REMOVED SENSITIVE VALUE***",
    "datadirectory": "***REMOVED SENSITIVE VALUE***",
    "dbtype": "mysql",
    "version": "",
    "overwrite.cli.url": "https:REMOVED SENSITIVE VALUE",
    "overwriteprotocol": "https",
    "dbname": "***REMOVED SENSITIVE VALUE***",
    "dbhost": "***REMOVED SENSITIVE VALUE***",
    "dbport": "",
    "dbtableprefix": "oc_",
    "mysql.utf8mb4": true,
    "dbuser": "***REMOVED SENSITIVE VALUE***",
    "dbpassword": "***REMOVED SENSITIVE VALUE***",
    "installed": true,
    "ldapIgnoreNamingRules": false,
    "ldapProviderFactory": "OCA\\User_LDAP\\LDAPProviderFactory",
    "enable_previews": false,
    "memcache.local": "\\OC\\Memcache\\APCu",
    "memcache.locking": "\\OC\\Memcache\\Redis",
    "maintenance": false,
    "mail_smtpmode": "smtp",
    "mail_sendmailmode": "smtp",
    "mail_from_address": "***REMOVED SENSITIVE VALUE***",
    "mail_domain": "***REMOVED SENSITIVE VALUE***",
    "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpport": "465",
    "mail_smtpsecure": "ssl",
    "mail_smtpauthtype": "LOGIN",
    "mail_smtpauth": 1,
    "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
    "mail_smtppassword": "***REMOVED SENSITIVE VALUE***"

The output of your Apache/nginx/system log in /var/log/____:

tail -f /var/log/httpd/error_log
[Tue Nov 26 03:43:01.773844 2019] [mpm_prefork:notice] [pid 9843] AH00163: Apache/2.4.6 (CentOS) PHP/7.2.10 configured -- resuming normal operations
[Tue Nov 26 03:43:01.773859 2019] [core:notice] [pid 9843] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
[Tue Nov 26 11:33:12.269700 2019] [mpm_prefork:notice] [pid 9843] AH00170: caught SIGWINCH, shutting down gracefully
[Tue Nov 26 11:33:19.612879 2019] [core:notice] [pid 1483] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
[Tue Nov 26 11:33:19.614959 2019] [suexec:notice] [pid 1483] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using fe80::1e4b:655f:3ca3:117b. Set the 'ServerName' directive globally to suppress this message
[Tue Nov 26 11:33:19.749782 2019] [lbmethod_heartbeat:notice] [pid 1483] AH02282: No slotmem from mod_heartmonitor
Cannot load Zend OPcache - it was already loaded
[Tue Nov 26 11:33:19.933599 2019] [mpm_prefork:notice] [pid 1483] AH00163: Apache/2.4.6 (CentOS) PHP/7.2.10 configured -- resuming normal operations
[Tue Nov 26 11:33:19.933630 2019] [core:notice] [pid 1483] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'

Can you please explain in details what you’re doing, what happens and what you expect to happen.

I mean the files with docx and xlsx file extension as I downloaded from nextcloud may cause the problem for reading and editing. So, I try to test that file extension change to as doc and xls, then is working fine. That’s my issue. Current my nextcloud setup is not integrated with onlyoffice. Just downloaded file (docx, xlsx, pptp extension) cann’t be accessible.

While accessing the error shown as below.


Are you accessing the files using the web browser or a WebDAV share? Which application do you want to use to open the files? Afaik, .doc/.xls and .docx/.xlsx are different file formats which cannot be renamed and opened straight away without prior conversation. Arre you sure that your application supports the file formats?

I am accessing the files from web browser. The uploaded files (.docx/.xlsx,.pptx) are downloaded from web browser. My problem is that files are not accessable. But I changed the file extension docx to doc / xlsx to xls via web browser, I redownload that same files. Can aceess and editable! I don’t know what was the issue? I just noticed that docx, xlsx file problem last week. Actually I have no issue for accessing that kind of file. It worked!

The web browser is usually responsible to associate the transfered file type or extension to an activity. So if .docx/.xlsx can be download but not opened with the right application, you should check the relevant browser settings first. In Firefox you find these settings unter “about:preferences” -> Applications