Private IP in URL

Hallo!
Ich entschuldige mich als erstes f├╝r meine Dummheit aber irgendwie komme ich nicht klar und brauche Eure Hilfe.
Ich habe mir jetzt einen Nextcloudserver in einem nspawn-Container unter Centos eingerichtet. Apache usw. konfiguriert und l├Ąuft auch soweit alles.
Ich habe da nur ein Problem an dem ich verzweifle: Wenn ich den Server von au├čen anspreche ├╝ber nextcloudPUNKTmeinedomainPUNKTcom lande ich auf der StandardWelcomePage des Apache (soweit so gut). Nun will ich auf den Nextcloudserver. Ich gebe also die URL ÔÇťnextcloudPUNKTmeinedomainPUNKTcom/nextcloudÔÇŁ ein und schicke das im Browser ab. Jetzt wird es merkw├╝rdig!!! Ich lande bei nextcloudPUNKTmeinedomainPUNKTcom/nextcloud/index.php. ABER er fragt mich dann direkt ob ÔÇťnextcloudPUNKTmeinedomainPUNKTcomÔÇŁ zu den trusted Domains hinzugef├╝gt werden soll OBWOHL diese so schon in der config.php drin steht!?! Wenn ich dann auf den Butten ÔÇťAdd nextcloudPUNKTmeinedomainPUNKTcom as ÔÇŽÔÇŁ wird es richtig merkw├╝rdig. Er zeigt dann n├Ąmlich in der URL meine private IP mit dem Pfad zur Best├Ątigung der trusted domain (https://192.168.0.1/index.php/settings/admin?trustDomain=nextcloud.meinedomain.com).
Ich habe schon so gut wie alles probiert: apache config editiert, config.php von nextcloud editiert, mit der /etc/hosts rumgespielt. Nix hilft. Wahrscheinlich l├Ąsst sich das Problem ganz einfach l├Âsen aber ich bin wohl zu dumm daf├╝r.
Es w├Ąre ganz toll wenn Ihr mir auf die Spr├╝nge helfen k├Ânnte.

Danke & Gru├č!
count0

P.S.: Falls sich jetzt jemand fragt wie ich zu nextcloud komme wenn eine private IP in der URL steht. Ich bin in dem Fall nat├╝rlich per VPN-Tunnel mit dem Netzwerk verbunden. Und nein der Tunnel an sich hat damit nix zu tun. Wenn ich den zu mache und ├╝ber das Inet gehe dann komme ich nur bis https://nextcloud.meinedomain.com/nextcloud/index.php danach geht dann nat├╝rlich nix mehr. :-/

P.P.S.: Sorry wg. der komischen Schreibweise der URL aber das geht als Newbie wohl nicht anders, aber ohne die URLs kann ich mein Problem schlecht darstellen. Alle URLS laufen ├╝ber https und den Rest k├Ânnt Ihr euch ja dann zusammenreimen. :wink:

OK. Habe das Problem jetzt einfach gel├Âst indem ich Nextcloud einfach nochmal aufgesetzt habe und dann den Wizard direkt beim ersten Mal mit der richtigen URL aufgerufen habe.
Ich finde das schon ein wenig doof dass man das nicht ├Ąndern kann und das auch die Eintr├Ąge unter trusted domain nicht ber├╝cksichtigt werden. Ist bestimmt so ein doofer DB-Eintrag der das dann immer wieder ├╝berschreibt/zur├╝cksetzt. Ich finde dass man das zur├╝cksetzen k├Ânnen sollte. :-/