Preview Generator PHP error

Nextcloud Version 13.0.5.2
Gallery Version 18
Preview Generator Version 1.1.0

When the ./occ preview:generate-all job runs, I get the following error. It seems to halt the job in its tracks. Any ideas on how I can resolve this issue?
Is there a way to setup the cronjob were it only searches inside a particular directory?

Error PHP imagecreatefromjpeg(): gd-jpeg: JPEG library reports unrecoverable error: Unsupported marker type 0x44 at /var/www/nextcloud/lib/private/legacy/image.php#573

I would open the JPG in Gimp or Photoshop, save it as JPG and try again.

@Sanook thanks for the reply.

I guess i dont know what JPEG to modify and or completely remove. Based on the error I thought the problem was with the cronjob finding the image.php file which is not a JPEG at all and has no JPEGs in it.
Its also very possible I just dont understand the error and am looking in the wrong place.

@Sanook as a test I located all the JPEG images in all my folders and removed them completely. Restarted Nextcloud and waited for the job to run again. Unfortunately I am still getting the same error.

What if you disable the cronjob and regenerate the preview images manually by executing

php occ preview:generate-all -vvv

-vvv should tell you which files have errors.

Ok, just tried that but it didn’t show any errors for my Photos folder.
I have another folder with lots of pictures in it but the job didnt seem to find that folder. When i look at the directory where Photos is located, I see my other folder but its not being picked up. Any ideas on why that might be?
I really appreciate your help @Sanook

Can you find them in the NC data folder on the server?

Yeah, its in the same location as my Photos directory

root@tinkerboard:/media/USBdrive/ncdata/dmiller/files# ls
Documents Photos Send to Phone Snow Baby

Snow Baby is the folder with a bunch of pictures that doesn’t seem to be found.

I’m wondering if its not finding my other Folder because its not getting past the error that I first reported. When I manually start the cronjob it runs for a couple minutes and stops. When I watch both the cronjob and my logs at the same time, the error pops up at the same time the job stops.

@Sanook I think I found my problem.
I re-ran occ preview:generate-all -vvv and found it kept stopping on one file. Turns out that file is .jpg but is a panoramic photo I took and is exceptionally large. I removed that file, started the cronjob again and it hasn’t errored out yet. Thanks once again for your help, wouldn’t have figured it out without you.

What are your thoughts on the job erroring due to a panoramic photo took on my Galaxy S9 phone?

Thank you!

I reckon it has XMP metadata added

https://developers.google.com/streetview/spherical-metadata

which is a feature request for Nextcloud:

Can you file a bug report on Github please?

Bug opened!