Prevent "storage full" on external storage?

Nextcloud version:
Operating system and version: Debian 10
Apache version: 2.4.38
PHP version: 7.3.9

Hi. I’m using an external storage that points to a FUSE mountpoint, which contains synthesized backups (from BorgBackup system).

It works fine, but each time I go inside the backup directory from NextCloud I get the " Your storage is full , files can not be updated or synced anymore !" message.
Indeed the storage is “full” because it is a constructed view, with no write possibility, and 0 free space.

I can’t find a way to prevent nextcloud to show this message each time. But the message should not be displayed because:

  • the directory of this external storage is mounted read-only (so updates are not possible)
  • this external storage is defined as “read-only” in “Parameters > External storage” configuration (so updates are not possible)

In my opinion this storage free space checking should not be performed on external storages with read-only flag.
More generally, as external storages can be “strange”, having an option to prevent any free space checking in external storage should be useful.

Is there any way to prevent this? Should I open a feature request about that?

Thanks. Best regards.

1 Like

Note: in the meanwhile I modified lib/private/Files/Storage/Local.php. It is not very “nice” but it prevent the message: in function free_space($path) if source path is not updatable (!$this->isUpdatable()) a “large” size is returned. It prevent read-only filesystems to be treated as “full”.
But a correct approach should be to deactivate “full storage” (and similar) messages in case of read-only mountpoints (more generally not writable mountpoints, which is not exactly the same).

Sounds like something that should be reported on GitHub directly, if not a related issue already exists:

Ok. I created it:

Did not found a related issue.