Pretty links not working


I followed this tutorial:

My Nextcloud is up and running, but I can’t for the life of me enable the use of pretty links.

I started digging into the server manual and found this:

mod_env and mod_rewrite are enabled.
I added the line htaccess.RewriteBase

I executed the occ command.

I restarted my apache2 service and rebooted my machine too, it’s still not working.

I’m at a loss here, what is not working correctly?

I have the following error log:
[Thu Nov 02 10:45:25.663433 2017] [mpm_prefork:notice] [pid 1797] AH00169: caught SIGTERM, shutting down
[Thu Nov 02 10:45:26.673956 2017] [ssl:warn] [pid 2430] AH01909: server certificate does NOT include an ID which matches the server name
[Thu Nov 02 10:45:26.709876 2017] [ssl:warn] [pid 2431] AH01909: server certificate does NOT include an ID which matches the server name
[Thu Nov 02 10:45:26.713421 2017] [mpm_prefork:notice] [pid 2431] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured – resuming normal operations
[Thu Nov 02 10:45:26.713444 2017] [core:notice] [pid 2431] AH00094: Command line: ‘/usr/sbin/apache2’


The occ maintenance:update:htaccess should have added some rewrite block to the end of your /path/to/nextcloud/.htaccess file, could you verify that/provide the last block of that file?

Recheck if your webserver really uses the .htaccess file. Provide the related webserver config file (AllowOverride All should be thwre), or just do a real check by adding some wanted syntax error to .htaccess and see if access to Nextcloud web ui breaks as expected.

Finally even if everything works as expected, your browser might have too much left in its cache. Try another browser or clear browser cache, just in case. Hmm this should properly have been done first :smile:.

Please try to add this statement to Nextclouds config.php:

‘htaccess.IgnoreFrontController’ => true,

I described the procedure here

Restart your browser and you should be fine?!
Cheers, Carsten

I fixed it! The fault was in my config.php.

‘htaccess.RewriteBase’ => ‘/nextcloud’, was into the array() instead of out of that. So I put ‘htaccess.RewriteBase’ => ‘/nextcloud’, outside of the array, issued the maintance:update command, restarted apache2 and now it works!

Thanks for your help!