Ports closed. No access from outside home network. But where's the problem?!

ups. sorry. ya. that’s true.

I think my fritzbox is not using the 443 port but 45063.
I was just going through the fritzbox interface again and I’m note quite sure about the settings regarding DHCPv6-Server in my network. Is there something that I maybe set up incorrectly?
I will try calling my provider and find out about dual stack in a sec.

should be the very next step.

are the little buttons close to your forwarding in your fritzbox green? that woulkd indicate the forwarding would be active and working

DHCP works differently as well for IPv6 :slight_smile: For now DHCP is only necessary to define the DNS server, that’s why I wrote:

Furthermore, it is totally fine to have an automatically assigned IPv6 address for now. For IPv6 IP addresses are assigned by Router Advertisements, not via DHCP.

Yes they’re green! Calling them now.

1 Like

ha, ok that I have done. Puh! :sweat_smile:

1 Like

we’re waiting on your “go” now about “double stack” :slight_smile:

So, a nice lady told me that she will give me an IPv4 address. It might take up to 24h to take effect she said.

1 Like

ya. could happen. but usually it’s way faster than that :slight_smile:

Here we go! I’ve got an IPv4 address now. :star_struck:

so now pls set up an ipv4 forwarding of port 80 and 443 to your local raspi from within your fritzbox. (to be sure pls turn off ipv6 forwarding for the moment)

Ok I have chosen the option IPv4. Not IPv6 and not both IPv4 and IPv6.

NCP wizard now says that ports are open.

rechable the way you wanted to reach it? even from the outside?

I set up DynDNS and I can use that address to access nextcloud from my mobile (wifi disconnected of course).
Lets encrypt ran through this time.

Does that mean I can now concentrate on trying to get everything as secure as possible and then actually start using it?!

apparently yes.
but i would suggest to let ncp do the security things for you. the maintainers know about how to setup sane security. as long as you set force https and have your ports open it should be working ok

Ok great!
I have run the security audit in the wizard. Oh boy, that is a very long list of issues… :see_no_evil:

@Schmu @JimmyKater @buckesfeld

Thank you all so so much for your help!!! You are brilliant!! :star2::bouquet::star2::bouquet::star2:

2 Likes

solved them already?

Will start tackling them tomorrow. For the rest of today I’ll enjoy that I took one step forward thanks to your help. :relaxed:

ok will be out for the next 14 days then, starting tomorrow. due to recharging batteries :wink:

if there will be issues that you can’t solve yourself there will be someone (hopefully) here to help you with them. if you would start a new thread for each occuring error… :slight_smile:
right now you should mark this thread solved…
was my pleasure