PicoCMS Step by step Instructions for installation and configuration


#1

Hi there,

i am a newbie regarding cms systems and currently trying to get PicoCMS up and running. Although the App installed without problems i can’t get my nextcloud server to display any sites from Pico.

I am sure that i am just missing a configuration step and would be thankful if anyone could point me to a step by step instruction (which files? What entries? …) so that i can resolve this.

Thanks in advance.


#2

Well. I have the same problem. I can’t put pico working with nextcloud

Need more detailed information how to configure the apache…


#3

Hi Richard,

Did you manage to get pico_cms working?

I’m using NextCloud on a Raspbery Pi and I can’t get Pico CMS to work. I think I’m stuck at how to incorporate the Apache settings.

Any advice you could give would be great!

Cheers,
Nic.


#4

I’ve quite trying to use pico
I’m not an informatic guy i was too much for me
If you have sucess let me know how


#5
  1. Update the nextcloud.conf in your /etc/apache2 config path.
  2. Restart the apache2.

/etc/apache2/sites-available# cat nextcloud.conf
Alias /nextcloud “/var/www/nextcloud/”

ProxyPass /sites/ http://localhost/index.php/apps/cms_pico/pico/
ProxyPassReverse /sites/ http://localhost/index.php/apps/cms_pico/pico/

RewriteEngine On
RewriteRule /sites/(.*) http://localhost/index.php/apps/cms_pico/pico/$1 [P]

<Directory /var/www/nextcloud/>
Options +FollowSymlinks
AllowOverride All

Dav off

SetEnv HOME /var/www/nextcloud
SetEnv HTTP_HOME /var/www/nextcloud

#

#6

OK. I tried the above and no go, so I tried the following.

Here’s the contents of my nextcloud.conf file in the /etc/apache2/sites-available folder

==================

Alias /nextcloud “/var/www/html/nextcloud/”

RewriteEngine On
RewriteRule /sites/(.*) https://mydomain.com/nextcloud/index.php/apps/cms_pico/pico/$1

<Directory /var/www/html/nextcloud/>
Options +FollowSymlinks
AllowOverride All

Dav off

SetEnv HOME /var/www/html/nextcloud
SetEnv HTTP_HOME /var/www/html/nextcloud

==============

After saving nextcloud.conf, I then restart apache.

If I then create a website called ‘test’ in the Pico-CMS app, the url given for that becomes

https://mydomain.com/sites/test

If I click that link in the Pico-CMS app, the browser opens up with the error.

=====================

Not Found

The requested URL /sites/test was not found on this server.

Apache/2.4.18 (Ubuntu) Server at 192.168.0.22 Port 443

=================

Am I missing something here? and if so should the

RewriteEngine On
RewriteRule /sites/(.*) https://mydomain.com/nextcloud/index.php/apps/cms_pico/pico/$1

be somewhere else. If so where.

Hoping this is one of those Duhhh moments.

Thanks

Nick


#7

Hi,
What version of Nextcloud ?


#8

The latest 13.0.1

Nick


#9

Has someone made PicoCMS work? It is supposed to be “easy” but it seems everybody is struggling to get it work, but without success?


#10

I got it to work on nextcloud 13.0.4 debian 9 with apache on php 7.2.

Don forget if you use Let’s encrypt the active config file is nextcloud-le-ssl.conf instead of nextcloud.conf.
Like ludovicis in another thread said (and the pico administrator settings suggest) you have to add before the start of <directory /your/files/>:

RewriteEngine On
RewriteRule /sites/(.*) https://yourdomain.com/index.php/apps/cms_pico/pico/$1 [QSA,L]

And to activate the changes:

(sudo) systemct restart apache2