Pico cms themes

Hi - I have had a look at a lot of posts here but don’t see where people have resolved this. Are there still issues with the pico_cms plugin?

My issues are:

I have installed the module, and have set up a site. The default theme is working perfectly. I would like to use my own theme though.

I have uploaded my theme to the nextcloud data/appdata directory, I can add it as administrator and as a user, I can apply it to my site.

This is where it gets tricky. I do not seem to be able to add any additional css files or javascript files. In my theme template.twig I have

<link rel='stylesheet' href="{{ theme_url }}/styles/style.css" type='text/css'/>
<link rel="stylesheet" href="{{ theme_url }}/style.css" type="text/css" />

These links get rendered as

<link rel="stylesheet" href="/apps/cms_pico/Pico/themes/default/styles/style.css" type='text/css'/>
<link rel="stylesheet" href="/apps/cms_pico/Pico/themes/default/style.css" type="text/css" />

The second stylesheet will load, but the first one will not. The first one will be redirected to the Nextcloud files app. The second one is copied from the default template. As far as I can see, the permissions are okay on all the folders and files.

Weirder are the scripts. In my twig template, I have

<script src="{{ theme_url }}/scripts/unslider-min.js"></script>
<script src="{{ theme_url }}/scripts/modernizr-2.6.1.min.js"></script>

which renders as

<script src="/apps/cms_pico/Pico/themes/default/scripts/unslider-min.js"></script>
<script src="/apps/cms_pico/Pico/themes/default/scripts/modernizr-2.6.1.min.js"></script>

The second has been copied from the default template, and the file moved into my theme. The first is not loaded, the second is.

Is there some setting somewhere that says which files can be added to the templates? I’ve been trying to find out what is going on, and am confused.

Any hints would be appreciated. Cheers


same here.
without custom theming pico_cms integration is not really useful.

I am having the same issue, the site is completely broken with the custom themes from the picocms page.

Is this plugin even still maintained?

Same here, nothing new about that ?

Was this ever resolved? It’s 2020 and I have this issue.

Can I chime in here?

Changing the default theme breaks the website.

The PicoCMS feature was announced with great pride on the nextcloud blog but is now completely broken…?

Same here. I played around with it and after trying to set it up, I tried to use a different theme and the whole site broke and looked terrible. Tried my best to play around with it, it did not take long to figure out that outside using the original theme, that I was going to have problems. Issue is that the theme page is vague and I had to check the Github page for the themes in question to realize that I was not doing anything wrong.

Since then, I have removed the App, since I could do the almost the same, for my needs, by using the README.md app, inside Files.

Not the optimal choice since I wanted a outward facing site but the solution above covered what I needed, in my use case.

I managed to fix it.

It is not straightforward, as all the themes seem to have different ways of installing and some depend on plugins to work.

PicoCMS is not Wordpress (where you can download and activate a theme with two clicks).

You’ll have to carefully read the (sometimes terse) README of the theme you want.
Make sure you have downloaded and activated any plugins the theme might depend on.

My knowledge comes from this issue on github.

1 Like