PHP zend_mm_heap corrupted / Segmentation fault errors

Nextcloud version 15.0.0:
Operating system and version Debian 9:
Apache 2.4.25:
PHP version7.3:

The issue I am facing:

I am getting multiple PHP related errors, in different use cases.
If I run occ I get a zend_mm_heap corrupted error on the console.
If I use the web UI I get Segmentation fault errors in the apache logs, this ranges form uploading files to installing a new app.

Reading search results for zend_mm_heap corruption I tried increasing the PHP output buffer up to 16K but this did not change the results.
I also tried different PHP versions: 7.0 7.2 and 7.3 all versions give the same result

The problem seems to go away for a short time (up to an hour) if I reboot the VM that is running Nextcloud.

At the moment the only thing I have not tied is changing the VM to Ubuntu 18.04. But I don’t know if this makes any difference since I have been running Nexcloud on Debian for years and never had any problems.
I hope someone recognizes this issue and can steer me the the right direction to fix it.

Kind regards,

The output of your Nextcloud log in Admin > Logging:

{"reqId":"oOiqYwYM7YnsN3SjSp3v","level":3,"time": "2019-01- 07T09:28:20+00:00","remoteAddr":"*****","user":"*****","app":"PHP","method":"GET","url":"\/settings\/user","message":"Allowed memory size of 536870912 bytes exhausted (tried to allocate 140120437485568 bytes) at \/usr\/local\/share\/nextcloud\/lib\/private\/BackgroundJob\/JobList.php#40","userAgent":"Mozilla\/5.0 (Windows NT 6.1; WOW64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/71.0.3578.85 Safari\/537.36 Vivaldi\/2.2.1388.34","version":""}

The output of your config.php file in /path/to/nextcloud:

$CONFIG = array (
  'instanceid' => '****************',
  'passwordsalt' => '*****************',
  'secret' => '*****************',
  'trusted_domains' =>
  array (
    0 => '',
  'datadirectory' => '/data/nextcloud/',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:5432',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'oc_**********',
  'dbpassword' => '*************',
  'htaccess.RewriteBase' => '/',
  'installed' => true,
  'ldapIgnoreNamingRules' => false,
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',
  'skeletondirectory' => '/data/next-skeleton/',
  'tempdirectory' => '/data/tmp/',
  'twofactor_enforced' => 'false',
  'twofactor_enforced_groups' =>
  array (
  'twofactor_enforced_excluded_groups' =>
  array (
  'mail_from_address' => 'cloud',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => '',
  'mail_smtphost' => '',

The output of your Apache/nginx/system log in /var/log/apache/error.log:

[Mon Jan 07 10:01:54.290832 2019] [core:notice] [pid 695] AH00052: child pid 1481 exit signal Segmentation fault (11)

As you run on a VM, lets all think we live in a marvellous world without VM bugs … what about your php logs ( from the server, not from NC )

you need to enable error display in the php.ini
Better check this:


php_flag  display_errors        on
php_value error_reporting       2039


Hi all,
Sorry for the radio silence on this issue.
I eventually “fixed” this by switching to Ubuntu server 18.04
Looking at PHP error logs did not help me much, maybe a developer could make more sense of it.
For me this issue is solved, but my opinion is that currently Nextcloud 15 does not run on Debian 9.