Php Warnings php7.3-gmp

Hallo Zusammen,

ich habe unter einem aktuellen Debian NextCloud 20.04 am laufen. Nach dem Update heute bekam ich eine Fehlermeldung die sehr oft auch im Log zu sehen ist, der ich gerne auf den Grund gehen möchte, komme aber leider nicht mehr weiter.
PHP Warning: PHP Startup: Unable to load dynamic library ‘php_gmp.so’
Das Modul war nicht installiert, ich habe es auf grund diesem Fahler nachinstalliert, php7.3-gmp, aber der Fehler bleibt. Ich habe nichts vernünftiges im Internet gefunden was mir und meinen nicht vorhandenen php Kenntnissen weiter hilf :frowning:

Habt ihr eine Idee für mich?

Viele Gesunde Grüße :slight_smile:

Hast Du den Webserver und gegebenenfalls php7-fpm neu gestartet?

Hi,

ich habe Aufgrund des Fehlers in die php.ini folgendes eingetragen:

extension=php_gmp.so

Dann den ganzen Server neugestartet.

fehler bleibt :frowning:

Prüfe, ob ein PHP-Modul names “php_gmp.so” im PHP-extensions-Verzeichnis auf Deinem Server existiert, bei mir heißt die Moduldatei nämlich “gmp.so”.

danke, wollte gerade mal die ganze fehlermeldung posten. Ich schaue gleich mal nach.

PHP Startup: Unable to load dynamic library ‘php_gmp.so’ (tried: /usr/lib/php/20180731/php_gmp.so (/usr/lib/php/20180731/php_gmp.so: cannot open shared object file: No such file or directory), /usr/lib/php/20180731/php_gmp.so.so (/usr/lib/php/20180731/php_gmp.so.so: cannot open shared object file: No such file or directory)) at Unknown#0

ja ist bei mir auch so, was tun?

Hast Du es schon einmal mit folgendem Konfigurationseintrag versucht:

extension=gmp.so

habe ich jetzt Versucht, geht auch nicht. Ich mache später weiter, ich muss zu einem termin.

Module ‘gmp’ already loaded at Unknown#0

Vielen Dank!

Woran erkenst du dass das Modul nicht geladen wird? Genau das Gegenteil ist der Fall, denn es wird versucht das Modul zweimal zu laden. Einmal vermutlich weil es fest einkompiliert wurde und einmal als Modul. Entferne dich einmal den gmp-Eintrag und schaue Dir dann an, ob das Modul korrekt geladen wird. Für das PHP CLI-Modul kann man z.B. “php -m” aufrufen.

ich hatte es erst eingetragen als die Fehlermeldung im Log aufgetaucht ist.

du hast recht, gmp ist geladen …

1 Like

Hallo Zusammen,

ich blieb noch die Lösung des Problems schuldig. Es war, nein die hatte ich nicht eingetragen, in der fpm php.ini nochmals eingetragen, dass das gmp Modul geladen werden soll. Damit gelöst, vielen Dank für die Unterstützung!