PHP Startup: Unable to load dynamic library '' after updating VM to NC v22

Yesterday I upgraded my NC from 21.0.3 to 22.0.0

Everything went well except a small thing.

Since the update (done by calling /var/scripts/ of the great VM) I get errors like:

PHP Startup: Unable to load dynamic library ‘’ (tried: /usr/lib/php/20190902/ (/usr/lib/php/20190902/ undefined symbol: zif_apcu_store), /usr/lib/php/20190902/ (/usr/lib/php/20190902/ cannot open shared object file: No such file or directory)) at Unknown#0

Looks like errors are caused by cron call.

Any idea where I can disable the loading of
Checked my cli config of php for apache and found no related entry.

Webserver: apache 2.4.x
php: 7.4
os: ubuntu 18.04
db: postgresql

Read some issues at GitHub about disabling apc in the VM I am asking if uninstalling apc is helpful here?

@szaimen Maybe you have a note for me?

We’ve recently replaced acpu with redis in the update script Remove APCu and replace with Redis instead by enoch85 · Pull Request #2040 · nextcloud/vm · GitHub maybe somewhere on your instance is still a config file that tries to load the acpu extension?

1 Like

Yes, seen this issue before.
Uninstalled apcu completly now and error is gone.
Will check my logs tomorrow morning after lot of crontab jobs had been running.

EDIT: Fixed it by purging apcu packages from the system.