PHP Module GD not installed. Error after CENTOS 7 kernel update

S[details=“Support intro”]

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

Nextcloud version 15.0.5_:
Operating system and version CENTOS 7 , kernel-3.10.0-957.10.1.el7.x86_64
Apache or nginx version (eg, Apache 2.4.25): httpd-2.4.6-88.el7.centos.x86_64
PHP version (eg, 7.1):

PHP Version 7.2.16

System Linux home 3.10.0-957.10.1.el7.x86_64 #1 SMP Mon Mar 18 15:06:45 UTC 2019 x86_64
Build Date Mar 5 2019 13:11:56
Server API Apache 2.0 Handler
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/opt/remi/php72
Loaded Configuration File /etc/opt/remi/php72/php.ini
Scan this dir for additional .ini files /etc/opt/remi/php72/php.d
Additional .ini files parsed …, /etc/opt/remi/php72/php.d/20-gd.ini, …

The issue you are facing:

All was working fine, until I updated the system and rebooted my home server after a new kernel was installed.

Now I get: PHP module GD not installed.

[root@home wp.rauchholz]# rpm -qa php72-php-gd

[root@home wp.rauchholz]# ls -al /opt/remi/php72/root/usr/lib64/php/modules/
-rwxr-xr-x 1 root root 108432 5. Mär 13:14 /opt/remi/php72/root/usr/lib64/php/modules/

and enabled
; Enable gd extension module

Is this the first time you’ve seen this error? (Y/N): Yes

Steps to replicate it:

  1. Go to

The output of your Nextcloud log in Admin > Logging:

Cannot access currently

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => '<secret>',
  'passwordsalt' => '<secret>',
  'secret' => '<secret>',
  'trusted_domains' =>
  array (
    0 => '',
  'datadirectory' => '/home/nextcloud_data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'nextclouddb',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '<secret>',
  'dbpassword' => '<secret>',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => '<secret>',
  'mail_domain' => '',
  'mail_smtphost' => '',
  'mail_smtpport' => '25',
  'maintenance' => false,
  'mail_smtpauthtype' => 'PLAIN',
  'mail_smtpauth' => 1,
  'theme' => '',
  'logfile' => '/var/log/html/nextcloud.log',
  'loglevel' => 8,
  'memcache.local' => '\\OC\\Memcache\\APCu',

The output of your Apache/nginx/system log in /var/log/____:


If you did use another php-version before do
a2dismod php<otherversion>
a2enmod php7.2