PHP memory problem

Hi, I´ve been changing the PHP memory configuration from automatic to 512M and now I can’t access trough internet explorer or chrome and dns address nighter

Can anyone tell me how can I change or restar the values without formating all please.

I have nextcloud in a Rock64 and I can’t access through ssh

Thanks in advance

How did you install, and how did you make changes to the config?

Trough internet explorer and nextcloud panel

Like this

The third picture of gif in the page. It’s the only way

And now I have this problem


Where have you changed the PHP settings?

For the intallation I downloaded a file in this page

I’ve choosed the rock 64

The PHP changes was made in this panel

First, main configuration is almost automatic and the you can go to the panel to chenge the nc-limits ( you can see it in teh video) there you put the size of PHP memory and files size


I’m trying to find exactly the menu where I’ve made the changes but I can’t

I access to the panel this way


Search “nc_limits”. Hopefully the correct setting.

Configuration-Reference | NextCloudPi Documentation


Configure system limits for NextCloudPi.

Note that MAXFILESIZE can be at maximum 2G for now, due to limitation of 32bit php.

How to configure

1. Navigate to `nc-limits` in the TUI or the WebUI.
2. Change `MAXFILESIZE` to the desired maximum file size (<=2G).
3. Change `MEMORYLIMIT` to the memory limit you want (default=768M).
4. Click Run or Start.
1 Like

OK, that’s the thing I did to change the maxfilesize and now I can’t access to the web panel configuration.

I was triying to connect via VPN and nothing.

Do you know if I can access to the rock 64 if I connect directly trough the router?

Sorry. I do not use an Nextcloudpi installation.

But perhaps you can login with ssh e.g. Putty and then

sudo ncp-config

How to configure NextCloudPi | NextCloudPi Documentation

I’ll try that.

Thanks so mucho for your time