PHP memory increase

image

How can I increase PHP memory by changing the configuration of several “.congif” but the value is still the same. I want to at least add 1 GB if I have it available. Or make it have no limit.

thank you.

Also set the memory increase to be = -1

The memory limit as shown in your screenshot is set in the php.ini of the php-sapi in use with the key “memory_limit

You did not give any information about your operating-system and the webserver you are using but looking at the loaded extensions (no cgi-fcgi), it appears that you have apache2 with the libapache2-mod-php sapi and not php-fpm in use.

If you are using a debianoid OS (like Ubuntu) you have to look in /etc/php/8.1/apache2/php.ini and set

memory_limit = 1G

and restart your webserver.

much luck!
ernolf

Hello, thanks for your time.
Install Ubuntu server and select when installing nextcloud… I hope you understand me…
I’m going to modify that information and see if it changes.

The location I found is in /etc/php/8.1/cli/php.ini

Ready, I changed the memory limit to 1G but it still doesn’t appear to use more memory in the php.

If you have installed Nextcloud via the Ubuntu Server installer you are using the Snap package, and you should be able to increase the PHP memory limit as follows: GitHub - nextcloud-snap/nextcloud-snap: ☁️📦 Nextcloud packaged as a snap

My intention is to view the files on the web page faster. In addition, when you log in, the faster it is. The system is placed in the VM with 10G of RAM, Ubuntu server.

How slow or fast is it now?

And how have you actually installed it?

PHP-FPM and configuring a memory cache like APCu would actully help a lot more to increase page load speeds, than just increasing the PHP memory limit.

If you’re using the Snap package you could also try to enable HTTP compression: GitHub - nextcloud-snap/nextcloud-snap: ☁️📦 Nextcloud packaged as a snap

Hello, thanks for your time . And trying to use that command but it gives me an error. Can’t find “SNAP”

$ sudo snap set nextcloud php.memory-limit=1G

So how did you install it?

And again, Increasing the PHP memory limit won’t help much with page load times. If you really want to see a difference you should configure PHP-FPM and APCu

The speed is the same, it hasn’t changed at all.

I installed it on Ubuntu Server with the default installer, when you are installing Ubuntu Server from scratch.

What would the latest PHP-FPM be like? Try searching for FMP but only CLI appears.

One last time: How fast or slow is it? 1 sec, 2 secs, 10 secs, 30 secs, a minute?

And for the third time: Increasing the PHP memory limit won’t help much with page load times. If you really want to see a difference you should also configure PHP-FPM and APCu

Logging in, uploading or viewing files takes an average of 10 seconds.
It has 4 cores in VM, 10 GB of ram.
Okay, I’ll check the PHP-FPM and APCu configuration. To see if web viewing improves.

If this is the time from logging in until the first file is open, it would say this is (almost) normal.

If every subsequent page load and every file you’re opening takes that long, it’s indeed way too slow.

However, APCu and FPM should defenitely improve things.

That’s right, it takes an average of 7-10 seconds to log in. For file uploads it is an average of 10 seconds, only the first time, that is. Reloading the page “F5” takes an average of 10 seconds, when you are already viewing the files and searching for different pages there is not much waiting time. But if you go from “documents” to “calendar” that is where that average takes. And when you log in or log out.

Ok. My instance takes maybe about 5-6 seconds, from hitting the Enter key on the Log-in screen untill I see the complete files list, and hitting F5 takes about 2-3 seconds. So don’t expect it to be instant, even with FPM and Memory cache enabled. But there is definitely room for improvement.

EDIT:
That was on a test instance. 2 Cores / 2GB

On my main instance (4 Cores / 8GB) it’s more like 3-4 Seconds for logging in and 1-2 Seconds for a page refresh.

Okay, at least improve 3 seconds for end users if that’s good. I will try to configure APCu and hope it improves.
Thanks for the help, I will mark the issue as resolved.