Php-fpm using 100% CPU

Hi,

I’m running NC12 at a server with 6 CPU cores. Currently, between 2 and 4 cores are at 100% usage due to php-fpm process.

Any hints?

Apps:

Enabled:
  - activity: 2.5.2
  - apporder: 0.4.0
  - bruteforcesettings: 1.0.2
  - comments: 1.2.0
  - dav: 1.3.0
  - federatedfilesharing: 1.2.0
  - federation: 1.2.0
  - files: 1.7.2
  - files_external: 1.3.0
  - files_sharing: 1.4.0
  - files_trashbin: 1.2.0
  - files_versions: 1.5.0
  - geolocation: 0.0.3
  - lookup_server_connector: 1.0.0
  - matrixbridge: 0.0.16
  - oauth2: 1.0.5
  - provisioning_api: 1.2.0
  - sharebymail: 1.2.0
  - systemtags: 1.2.0
  - twofactor_backupcodes: 1.1.1
  - updatenotification: 1.2.0
  - user_ldap: 1.2.1
  - user_ldap_extended: 0.0.6
  - workflowengine: 1.2.0

Nextcloud version : 12.0.0
Operating system and version : Debian Strech
Apache or nginx version: Apache 2.4.25
PHP version : 7.0
Is this the first time you’ve seen this error?: yes

Can you reliably replicate it? (If so, please outline steps): yes, the cpu usage is constant

The issue you are facing: Between 2 and 4 cores are at 100% usage due to php-fpm process.

The output of your Nextcloud log in Admin > Logging: nothing related

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => '***',
  'passwordsalt' => '***',
  'secret' => '***',
  'trusted_domains' => 
  array ( ***
  ),
  'datadirectory' => '***',
  'overwrite.cli.url' => '***',
  'dbtype' => 'mysql',
  'version' => '12.0.0.29',
  'dbname' => '***',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'nextcloud',
  'dbpassword' => ***,
  'installed' => true,
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
  ),
  'ldapIgnoreNamingRules' => false,
  'ldapProviderFactory' => '\\OCA\\User_LDAP\\LDAPProviderFactory',
  'loglevel' => 3,
  'maintenance' => false
);

How much memory do you have available? Also, are there any errors in the Apache log?

I have currently 16GB, from which only 2.5 are taken right now.

No!

we have currently around 20 users.

best

When you change the loglevel you can obtain more warning and notification messages. Check your database settings, there is in general a huge potential to speed things up (mysqltuner and tuningprimer are script that can help you to analyze your settings). System cronjob instead of webcron or ajax…

The same thing seems to be happening to me as well.
It starts when opening the calendar. My default calendar never loads and maybe causes the 100%. All calenders do work when syncing via caldav.
I need to restart php-fpm to resolve the usage.

The same for me, after upgrading from 11.0.x to 12.0.x . 100% Core usage per unsuccessful attempt to open Webui calendar.

See this old post:

I’m curious why there’s no “investigation” on this issue.

I opened an issue on github, as this is the preferred way to report bugs.

Issue was closed because I posted it in the wrong repository. Sry

New Issue:

Confirmed - manual fix works.