Php-fpm not responding to nginx requests -- 504 Gateway Time-out

From browser when i fireup the nextcloud instance – the nginx webserver picks it up. But I don’t see any CPU activity on php-fpm. There is nothing in the debug log file. Its passive to the request on the socket. Eventually nginx times out.

How to debug this?

In order to say anything meaningfull, you should provide more detailed information about your server and how it is set up and configured.

  • Baremetal, Snap, Docker, AIO?
  • What OS?
  • What Nextcloud Version
  • DNS and Network architecture
  • Logfile entries


Much and good luck,

Thank you. In order to enable access logs, I had set the php install prefix , i.e. “php-fpm -p” to /var/www/run. I moved the conf files and php-fpm. to /var/ww/run/etc directory. After this I don’t get the error anymore. However, i do get the `

``Access through untrusted domain

Please contact your administrator. If you are an administrator, edit the “trusted_domains” setting in config/config.php like the example in config.sample.php. ```

For now I will mark this as solved and raise a separate post for that if required.