PHP-FPM configuration not working with enableapp.php

I’m using php7.0-fpm along with mod_fcgid, mod_proxy, and mod_rewrite to get Apache to send the right information to PHP to serve the pages via FPM.

My relevant <VirtualHost> entry has this to do the forwarding:

        AcceptPathInfo On
        DocumentRoot /var/www/nextcloud
        SetEnv proxy-fcgi-pathinfo last-dot
        SetEnv front_controller_active true

        <Proxy fcgi://unique-domain-name-string>
                ProxySet connectiontimeout=5 timeout=240
        <FilesMatch "\.php$">
                SetHandler "proxy:unix:/run/php/php7.0-fpm.sock|fcgi://unique-domain-name-string/"

        RewriteCond %{REQUEST_FILENAME} \.php$
        RewriteCond %{DOCUMENT_ROOT}/%{REQUEST_URI} !-f
        RewriteRule (.*) - [H=text/html]

It works well enough, but one thing doesn’t work from the web (although it works fine using occ: I cannot enable/disable applications. It seems that when you click the Enable button on the web page, it does a POST to /index.php/settings/ajax/enableapp.php.

This bit (two .php files on the path) seems to throw my config into a bit of a tizzy, returning the source code of the index.php file. If I edit the request and send it instead without the /index.php and leave the rest, the command executes successfully. I’ve tried changing proxy-fcgi-pathinfo last-dot to proxy-fcgi-pathinfo first-dot, but it made no difference.

You figured out the javascript issue?

Yeah, thanks. The solution above works for almost everything, but not quite. Ideally the app shouldn’t be putting the index.php on the path in this situation.

Received service unavailable from apache/php5-fpm
Adding this seems to have fixed something:
ProxyPassMatch ^/(..php(/.)?)$ unix://var/run/php5-fpm.sock|fcgi://

The box: Linux ppkl-randd 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt25-2 (2016-04-08) x86_64 GNU/Linux

Can someone help me with this issue with php 7.0. This is what i ran in to when I upgraded to nextcloud 11 and php 7.0 : I opened nextcloud and this is what I got: PHP GO or GD or something like that. Have you heard of any php issues. This is what i got when when I try to open next cloud : PHP module zip not installed. PHP module dom not installed. PHP module XMLWriter not installed. PHP module XMLReader not installed. PHP module libxml not installed. PHP module mb multibyte not installed. PHP module GD not installed. SimpleXML not installed. PHP module cURL not installed. PHP modules have been installed, but they are still listed as missing? Please ask your server administrator to restart the web server. has any one ran into this and how do I get around it.