PHP-Error Undefined index: PHP_AUTH_USER at ... CORSMiddleware.php#88

Only when using the Firefox Addon “Nextcloud Passwords” on Android, i get the above Error-Message in my Server-Log and Firefox on Android tells me: “Server crashed during Request”

Used Firefox on Android: 58.0.2

Server is Nextcloud 15.0.2 (in “owncloud”- apache directory)

Am i the only one facing this problem?

After the first Error, the full log is:
PHP-Error Undefined index: PHP_AUTH_USER at … CORSMiddleware.php#88

1.Undefined index: PHP_AUTH_USER at /srv/www/htdocs/owncloud/lib/private/AppFramework/Middleware/Security/CORSMiddleware.php#88

{“reqId”:“XG7Md4xtYHMDwDHS8AGpEAAAABM”,“level”:3,“time”:“2019-02-21T16:06:16+00:00”,“remoteAddr”:“89.183.221.25”,“user”:"–",“app”:“PHP”,“method”:“GET”,“url”:"/owncloud/index.php/apps/passwords/api/0.1/passwords",“message”:“Undefined index: PHP_AUTH_USER at /srv/www/htdocs/owncloud/lib/private/AppFramework/Middleware/Security/CORSMiddleware.php#88”,“userAgent”:“Mozilla/5.0 (Android 7.1.2; Mobile; rv:58.0) Gecko/58.0 Firefox/58.0”,“version”:“15.0.2.0”,“id”:“5c6ecc787f547”}

2.Undefined index: PHP_AUTH_PW at /srv/www/htdocs/owncloud/lib/private/AppFramework/Middleware/Security/CORSMiddleware.php#89

{“reqId”:“XG7Md4xtYHMDwDHS8AGpEAAAABM”,“level”:3,“time”:“2019-02-21T16:06:16+00:00”,“remoteAddr”:“89.183.221.25”,“user”:"–",“app”:“PHP”,“method”:“GET”,“url”:"/owncloud/index.php/apps/passwords/api/0.1/passwords",“message”:“Undefined index: PHP_AUTH_PW at /srv/www/htdocs/owncloud/lib/private/AppFramework/Middleware/Security/CORSMiddleware.php#89”,“userAgent”:“Mozilla/5.0 (Android 7.1.2; Mobile; rv:58.0) Gecko/58.0 Firefox/58.0”,“version”:“15.0.2.0”,“id”:“5c6ecc787f518”}

3.TypeError: Argument 1 passed to OC\Authentication\Token\Manager::getToken() must be of the type string, null given, called in /srv/www/htdocs/owncloud/lib/private/User/Session.php on line 488

{“reqId”:“XG7Md4xtYHMDwDHS8AGpEAAAABM”,“level”:3,“time”:“2019-02-21T16:06:16+00:00”,“remoteAddr”:“89.183.221.25”,“user”:"–",“app”:“index”,“method”:“GET”,“url”:"/owncloud/index.php/apps/passwords/api/0.1/passwords",“message”:{“Exception”:“TypeError”,“Message”:“Argument 1 passed to OC\Authentication\Token\Manager::getToken() must be of the type string, null given, called in /srv/www/htdocs/owncloud/lib/private/User/Session.php on line 488”,“Code”:0,“Trace”:[{“file”:"/srv/www/htdocs/owncloud/lib/private/User/Session.php",“line”:488,“function”:“getToken”,“class”:“OC\Authentication\Token\Manager”,“type”:"->",“args”:["*** sensitive parameters replaced "]},{“file”:"/srv/www/htdocs/owncloud/lib/private/User/Session.php",“line”:406,“function”:“isTokenPassword”,“class”:“OC\User\Session”,“type”:"->",“args”:[" sensitive parameters replaced "]},{“file”:"/srv/www/htdocs/owncloud/lib/private/AppFramework/Middleware/Security/CORSMiddleware.php",“line”:93,“function”:“logClientIn”,“class”:“OC\User\Session”,“type”:"->",“args”:[" sensitive parameters replaced ***"]},{“file”:"/srv/www/htdocs/owncloud/lib/private/AppFramework/Middleware/MiddlewareDispatcher.php",“line”:95,“function”:“beforeController”,“class”:“OC\AppFramework\Middleware\Security\CORSMiddleware”,“type”:"->",“args”:[{“class”:“OCA\Passwords\Controller\Api\Legacy\LegacyPasswordApiController”},“index”]},{“file”:"/srv/www/htdocs/owncloud/lib/private/AppFramework/Http/Dispatcher.php",“line”:98,“function”:“beforeController”,“class”:“OC\AppFramework\Middleware\MiddlewareDispatcher”,“type”:"->",“args”:[{“class”:“OCA\Passwords\Controller\Api\Legacy\LegacyPasswordApiController”},“index”]},{“file”:"/srv/www/htdocs/owncloud/lib/private/AppFramework/App.php",“line”:118,“function”:“dispatch”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:"->",“args”:[{“class”:“OCA\Passwords\Controller\Api\Legacy\LegacyPasswordApiController”},“index”]},{“file”:"/srv/www/htdocs/owncloud/lib/private/AppFramework/Routing/RouteActionHandler.php",“line”:47,“function”:“main”,“class”:“OC\AppFramework\App”,“type”:"::",“args”:[“LegacyPasswordApiController”,“index”,{“class”:“OC\AppFramework\DependencyInjection\DIContainer”},{"_route":“passwords.legacy_password_api.index”}]},{“function”:"__invoke",“class”:“OC\AppFramework\Routing\RouteActionHandler”,“type”:"->",“args”:[{"_route":“passwords.legacy_password_api.index”}]},{“file”:"/srv/www/htdocs/owncloud/lib/private/Route/Router.php",“line”:297,“function”:“call_user_func”,“args”:[{“class”:“OC\AppFramework\Routing\RouteActionHandler”},{"_route":“passwords.legacy_password_api.index”}]},{“file”:"/srv/www/htdocs/owncloud/lib/base.php",“line”:987,“function”:“match”,“class”:“OC\Route\Router”,“type”:"->",“args”:["/apps/passwords/api/0.1/passwords"]},{“file”:"/srv/www/htdocs/owncloud/index.php",“line”:42,“function”:“handleRequest”,“class”:“OC”,“type”:"::",“args”:[]}],“File”:"/srv/www/htdocs/owncloud/lib/private/Authentication/Token/Manager.php",“Line”:113,“CustomMessage”:"–"},“userAgent”:“Mozilla/5.0 (Android 7.1.2; Mobile; rv:58.0) Gecko/58.0 Firefox/58.0”,“version”:“15.0.2.0”,“id”:“5c6ecc787f4e2”}

Updated to Firefox 65.0.1 -> same behaviour

Can you check the settings of the extension if the username and password are entered correctly?

If PHP_AUTH_USER and PHP_AUTH_PW are missing, either the settings are incomplete or the authorization header goes missing somewhere on the way.

i did - i used some other users and android-devices to check. seems to be the same. field “user”:"–" in log is emtpy - i definitivly entered something there in the settings, but result is the same even if i enter nothing.
On linux / firefox and win / firefox the ff-plugin works smooth.

maybe there is a problem with nextcloud not beeing on top-level of the domain? i would guess, cause the app doesn’t work also (networking error when entering the serveradress).