PHP 8.3.6 - issue with update to 26.0.13

Hi all,

I’ve updated my nextcloud with commad line after updating PHP to v8.3.6 (embedded with Ubuntu 24.04 distrib)…

sudo -u www-data php8.3 updater/updater.phar  --no-interaction

I’m now having this message when requesting the cloud from web browser :

This version of Nextcloud is not compatible with PHP>=8.3.
You are currently running 8.3.6.

and when I’m trying to run ./occ upgrade I get this message :

This version of Nextcloud is not compatible with PHP>=8.3.
You are currently running 8.3.6.

Is there a way to fix that quickly ?
Should I change a config param to update to a more recent version, even if not stable ?

Please tell me what should I do ! Many thanks in advance,

Simon

Please search the forum. This issue has many posts.

In short words:
You have to downgrade your php version.
After update of NC you can upgrade it again.

2 Likes

In the future, to avoid trouble, check the Server Requirements for your existing and target versions of Nextcloud - e.g.

See https://docs.nextcloud.com/ for other versions.

1 Like